summaryrefslogtreecommitdiff
path: root/test/regression
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2010-03-03 13:22:44 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2010-03-03 13:22:44 +0000
commit54cba6d4cae1538887f296a62be1c99378fe0916 (patch)
tree18e31413aa420490e37722f6f585d3f2f5277b40 /test/regression
parent1e24932c5f5badcca3125b9c4c0df2ac113532bf (diff)
Suppressed -fall-extensions option, too dangerous wrt flonglong
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1275 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/regression')
-rw-r--r--test/regression/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/regression/Makefile b/test/regression/Makefile
index 2af20e6..cc8684c 100644
--- a/test/regression/Makefile
+++ b/test/regression/Makefile
@@ -1,7 +1,8 @@
include ../../Makefile.config
CCOMP=../../ccomp
-CCOMPFLAGS=-stdlib ../../runtime -dparse -dclight -dasm -fall-extensions
+CCOMPFLAGS=-stdlib ../../runtime -dparse -dclight -dasm \
+ -fstruct-passing -fstruct-assign -fbitfields
LIBS=$(LIBMATH)
@@ -30,7 +31,7 @@ clean:
rm -f *.compcert
rm -f *.parsed.c *.light.c *.s *.o *~
-test_compcert:
+test:
@for i in $(TESTS); do \
if ./$$i.compcert | cmp -s - Results/$$i; \
then echo "$$i: passed"; \