summaryrefslogtreecommitdiff
path: root/test/regression/Results
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-08-18 14:50:19 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-08-18 14:50:19 +0000
commit50ee6bdf639ffba989968abb9c24a57126ab35a4 (patch)
tree80e123d295a84372b13739b6905d583fa9bbe700 /test/regression/Results
parent62a07ee96d51c29bab9668d8c41bf5f8bdf9e23d (diff)
Presimplification SimplVolatile: cleaned up and integrated.
test/*/Makefile: normalized 'bench' target git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1717 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/regression/Results')
-rw-r--r--test/regression/Results/volatile338
1 files changed, 38 insertions, 0 deletions
diff --git a/test/regression/Results/volatile3 b/test/regression/Results/volatile3
new file mode 100644
index 0000000..3d1f786
--- /dev/null
+++ b/test/regression/Results/volatile3
@@ -0,0 +1,38 @@
+x = 0
+x = 1
+x++ = 1
+x = 2
+x = 44
+x += 12 = 56
+x = 56
+x = 55
+x-- = 55
+x = 54
+x = 47
+x -= 3 = 44
+x = 44
+x = 45
+++x = 46
+x = 46
+x = 45
+--x = 44
+x = 44
+c = 0
+c = 1
+c++ = 1
+c = 2
+c = 252
+c += 42 = 38
+c = 38
+c = 37
+c-- = 37
+c = 36
+c = 29
+c -= 3 = 26
+c = 26
+c = 27
+++c = 28
+c = 28
+c = 27
+--c = 26
+c = 26