summaryrefslogtreecommitdiff
path: root/test/regression/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2010-03-03 10:22:27 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2010-03-03 10:22:27 +0000
commit891377ce1962cdb31357d6580d6546ec22df2b4f (patch)
tree4ff7c38749cc7a4c1af411c5aa3eb7225c4ae6a1 /test/regression/Makefile
parent018edf2d81bf94197892cf1df221f7eeac1f96f6 (diff)
Switching to the new C parser/elaborator/simplifier
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1269 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/regression/Makefile')
-rw-r--r--test/regression/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/test/regression/Makefile b/test/regression/Makefile
new file mode 100644
index 0000000..2af20e6
--- /dev/null
+++ b/test/regression/Makefile
@@ -0,0 +1,40 @@
+include ../../Makefile.config
+
+CCOMP=../../ccomp
+CCOMPFLAGS=-stdlib ../../runtime -dparse -dclight -dasm -fall-extensions
+
+LIBS=$(LIBMATH)
+
+# Can run and have reference output in Results
+TESTS=bitfields1 expr1 initializers
+
+# Other tests: should compile to .s without errors (but expect warnings)
+EXTRAS=commaprec expr2 expr3 expr4 extern1 funct2 funptr1 init1 \
+ init2 init3 init4 pragmas ptrs1 ptrs2 sizeof1 struct1 struct2 struct3 \
+ struct4 struct5 struct6 types1 volatile1
+
+# Test known to fail
+FAILURES=funct1 varargs1
+
+all_s: $(TESTS:%=%.s) $(EXTRAS:%=%.s)
+
+all: $(TESTS:%=%.compcert) $(EXTRAS:%=%.s)
+
+%.compcert: %.c $(CCOMP)
+ $(CCOMP) $(CCOMPFLAGS) -o $*.compcert $*.c $(LIBS)
+
+%.s: %.c $(CCOMP)
+ $(CCOMP) $(CCOMPFLAGS) -S $*.c
+
+clean:
+ rm -f *.compcert
+ rm -f *.parsed.c *.light.c *.s *.o *~
+
+test_compcert:
+ @for i in $(TESTS); do \
+ if ./$$i.compcert | cmp -s - Results/$$i; \
+ then echo "$$i: passed"; \
+ else echo "$$i: FAILED"; \
+ fi; \
+ done
+