summaryrefslogtreecommitdiff
path: root/test/regression/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-03-09 09:43:17 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-03-09 09:43:17 +0000
commit06c55ab8fa4c0bf59479faf03d30a51c780da36e (patch)
tree7d843aa10b43e96724d0717b1ab36fbef3e32ee6 /test/regression/Makefile
parent4b23f9300df9e2f532745f2810aaa1e0d61f08d8 (diff)
Treat "char" as unsigned OR signed depending on the configuration.
Fixed infinite expansion of some recursive struct type where recursion goes through a typeded. git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1596 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/regression/Makefile')
-rw-r--r--test/regression/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/regression/Makefile b/test/regression/Makefile
index a385cc4..eda31de 100644
--- a/test/regression/Makefile
+++ b/test/regression/Makefile
@@ -11,12 +11,12 @@ LIBS=$(LIBMATH)
TESTS=bitfields1 bitfields2 bitfields3 bitfields4 \
bitfields5 bitfields6 bitfields7 \
expr1 initializers volatile2 \
- funct3 expr5 struct7 struct8 casts1 casts2
+ funct3 expr5 struct7 struct8 casts1 casts2 char1
# Other tests: should compile to .s without errors (but expect warnings)
EXTRAS=annot1 commaprec expr2 expr3 expr4 extern1 funct2 funptr1 init1 \
init2 init3 init4 pragmas ptrs1 ptrs2 sizeof1 struct1 struct2 struct3 \
- struct4 struct5 struct6 struct9 types1 volatile1
+ struct4 struct5 struct6 struct9 struct10 types1 volatile1
# Test known to fail
FAILURES=funct1 varargs1