summaryrefslogtreecommitdiff
path: root/test/compression
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2014-07-28 12:13:15 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2014-07-28 12:13:15 +0000
commit04d0d602ef7245fd566debd91bcb148acd9ed067 (patch)
tree77a11f3e551303521aa72af1e63cea0285bcd1bc /test/compression
parentb8e535ccf82385573f80f6d146c04892b25ea0a6 (diff)
PowerPC port: refactored the expansion of built-in functions and
pseudo-instructions so that it does not need to be re-done in cchecklink. cchecklink: updated accordingly. testsuite: compile with -sdump and run cchecklink if supported. git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2553 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/compression')
-rw-r--r--test/compression/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/test/compression/Makefile b/test/compression/Makefile
index 8db55dd..e35e1a1 100644
--- a/test/compression/Makefile
+++ b/test/compression/Makefile
@@ -1,7 +1,13 @@
+include ../../Makefile.config
+
CC=../../ccomp
CFLAGS=-U__GNUC__ -stdlib ../../runtime -dclight -dasm
LIBS=
TIME=xtime -o /dev/null -mintime 1.0
+ifeq ($(CCHECKLINK),true)
+CCHECK=../../cchecklink
+CFLAGS+= -sdump
+endif
EXE=arcode lzw lzss
@@ -51,10 +57,18 @@ bench:
done
rm -f $(TESTCOMPR)
+ccheck:
+ @echo "---- arcode"
+ @$(CCHECK) -exe arcode $(ARCODE_OBJS:.o=.sdump)
+ @echo "---- lzw"
+ @$(CCHECK) -exe lzw $(LZW_OBJS:.o=.sdump)
+ @echo "---- lzss"
+ @$(CCHECK) -exe lzss $(LZSS_OBJS:.o=.sdump)
+
include .depend
clean:
- rm -f *.o *.light.c *.s $(EXE)
+ rm -f *.o *.light.c *.s *.sdump $(EXE)
depend:
gcc -MM *.c > .depend