summaryrefslogtreecommitdiff
path: root/test/c/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2006-10-22 08:14:51 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2006-10-22 08:14:51 +0000
commitb6bdb4b4924b0934aed24335597a89e49f7cbd61 (patch)
treef69d59843e463d3345a987660ac7c1f43f33c268 /test/c/Makefile
parent0b3920e6fd26f05e2ddad19cfd8b224c150ebfd1 (diff)
Ajout et utilisation de compcert_stdio.h
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@123 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/c/Makefile')
-rw-r--r--test/c/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/test/c/Makefile b/test/c/Makefile
index 9f3c553..16fead4 100644
--- a/test/c/Makefile
+++ b/test/c/Makefile
@@ -1,13 +1,11 @@
CCOMP=../../ccomp
-CCOMPFLAGS=-dump-c
+CCOMPFLAGS=-dump-c -I../lib
-CC=gcc -arch ppc # MacOS X
-#CC=gcc # other systems
+CC=gcc -arch ppc
CFLAGS=-O1 -Wall
-LIBS= # MacOS X
-#LIBS=-lm # other systems
+LIBS=
TIME=xtime -o /dev/null -mintime 1.0 # Xavier's hack
#TIME=time >/dev/null # Otherwise
@@ -23,7 +21,7 @@ all: $(PROGS:%=%.compcert)
all_gcc: $(PROGS:%=%.gcc)
%.compcert: %.s
- $(CC) $(CFLAGS) -o $*.compcert $*.s $(LIBS)
+ $(CC) $(CFLAGS) -o $*.compcert $*.s ../lib/libcompcert.a $(LIBS)
%.s: %.c ../../ccomp
$(CCOMP) $(CCOMPFLAGS) $*.c