summaryrefslogtreecommitdiff
path: root/test/c/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2010-02-17 13:44:32 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2010-02-17 13:44:32 +0000
commit6224148fdd809170d138216d72b8e6180d626aec (patch)
treef67127b4ab6026f5e29d0b6aa69bec4f8a223fb2 /test/c/Makefile
parentf9ebf19ba3ca4c3ee67cc88bbea407d4dd734249 (diff)
Reorganization test directory
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1253 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/c/Makefile')
-rw-r--r--test/c/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/test/c/Makefile b/test/c/Makefile
index 060c8fc..1284d98 100644
--- a/test/c/Makefile
+++ b/test/c/Makefile
@@ -10,13 +10,11 @@ LIBS=$(LIBMATH)
TIME=xtime -o /dev/null -mintime 1.0 # Xavier's hack
#TIME=time >/dev/null # Otherwise
-BENCHS=fib integr qsort fft sha1 aes almabench lists \
+PROGS=fib integr qsort fft sha1 aes almabench lists \
binarytrees fannkuch knucleotide mandelbrot nbody \
nsieve nsievebits spectral vmach \
bisect chomp perlin
-PROGS=$(BENCHS) initializers
-
all_s: $(PROGS:%=%.s)
all: $(PROGS:%=%.compcert)
@@ -26,7 +24,7 @@ all_gcc: $(PROGS:%=%.gcc)
%.compcert: %.c $(CCOMP)
$(CCOMP) $(CCOMPFLAGS) -o $*.compcert $*.c $(LIBS)
-%.s: %.c ../../ccomp
+%.s: %.c $(CCOMP)
$(CCOMP) $(CCOMPFLAGS) -S $*.c
%.gcc: %.c