summaryrefslogtreecommitdiff
path: root/test/c/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2012-06-28 07:59:03 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2012-06-28 07:59:03 +0000
commit5312915c1b29929f82e1f8de80609a277584913f (patch)
tree0f7ee475743f0eb05d352148a9e1f0b861ee9d34 /test/c/Makefile
parentf3250c32ff42ae18fd03a5311c1f0caec3415aba (diff)
Use Flocq for floats
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1939 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/c/Makefile')
-rw-r--r--test/c/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/test/c/Makefile b/test/c/Makefile
index 2b9f4b7..5fd3f55 100644
--- a/test/c/Makefile
+++ b/test/c/Makefile
@@ -13,7 +13,9 @@ TIME=xtime -o /dev/null -mintime 1.0 # Xavier's hack
PROGS=fib integr qsort fft sha1 aes almabench lists \
binarytrees fannkuch knucleotide mandelbrot nbody \
nsieve nsievebits spectral vmach \
- bisect chomp perlin
+ bisect chomp perlin floats
+
+PROGS_INTERP=floats
all_s: $(PROGS:%=%.s)
@@ -37,6 +39,12 @@ test:
else echo "$$i: FAILED"; \
fi; \
done
+ @for i in $(PROGS_INTERP); do \
+ if $(CCOMP) -interp -quiet $$i.c | cmp -s - Results/$$i; \
+ then echo "$$i (interpreted): passed"; \
+ else echo "$$i (interpreted): FAILED"; \
+ fi; \
+ done
test_gcc:
@for i in $(PROGS); do \