summaryrefslogtreecommitdiff
path: root/test/c/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-04-20 08:42:06 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-04-20 08:42:06 +0000
commit0c805fe28e5ebdf4890dd42f5c12a85ee61bafc5 (patch)
tree7ad5f4b4c87a7a0f9f22a1da87f7e1fa2db4df7f /test/c/Makefile
parentfe8a84e1212f14fa05626abe03dd91cdc9dcc3db (diff)
Tests "floats" and "floats-basics" moved from test/c to test/regression
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2202 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/c/Makefile')
-rw-r--r--test/c/Makefile10
1 files changed, 1 insertions, 9 deletions
diff --git a/test/c/Makefile b/test/c/Makefile
index a11ab69..d3f0d16 100644
--- a/test/c/Makefile
+++ b/test/c/Makefile
@@ -13,9 +13,7 @@ TIME=xtime -o /dev/null -mintime 1.0 # Xavier's hack
PROGS=fib integr qsort fft sha1 aes almabench lists \
binarytrees fannkuch knucleotide mandelbrot nbody \
nsieve nsievebits spectral vmach \
- bisect chomp perlin siphash24 floats floats-basics
-
-PROGS_INTERP=floats floats-basics
+ bisect chomp perlin siphash24
all: $(PROGS:%=%.compcert)
@@ -39,12 +37,6 @@ test:
else echo "$$i: FAILED"; \
fi; \
done
- @for i in $(PROGS_INTERP); do \
- if $(CCOMP) -interp -quiet $$i.c | cmp -s - Results/$$i; \
- then echo "$$i (interpreted): passed"; \
- else echo "$$i (interpreted): FAILED"; \
- fi; \
- done
test_gcc:
@for i in $(PROGS); do \