summaryrefslogtreecommitdiff
path: root/test/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-03-10 10:11:25 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-03-10 10:11:25 +0000
commit1132f0865a3d5fe3dd43b1d2d9c4580e10436107 (patch)
tree165aa6872f99fbfe1d4cbb4e49e95b2ab8325974 /test/Makefile
parent3ffda353b0d92ccd0ff3693ad0be81531c3c0537 (diff)
Improved test harness
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1598 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test/Makefile')
-rw-r--r--test/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/Makefile b/test/Makefile
new file mode 100644
index 0000000..d29cd8d
--- /dev/null
+++ b/test/Makefile
@@ -0,0 +1,10 @@
+DIRS=c compression raytracer spass regression
+
+all:
+ for i in $(DIRS); do $(MAKE) -C $$i all; done
+
+test:
+ for i in $(DIRS); do $(MAKE) -C $$i test; done
+
+clean:
+ for i in $(DIRS); do $(MAKE) -C $$i clean; done