summaryrefslogtreecommitdiff
path: root/pg
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-03-09 13:35:00 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-03-09 13:35:00 +0000
commit3ffda353b0d92ccd0ff3693ad0be81531c3c0537 (patch)
tree9a07da4e83919d763086e379de161fd4cfe8ab02 /pg
parent06c55ab8fa4c0bf59479faf03d30a51c780da36e (diff)
Updated for Coq 8.3pl1. Some cleanups in test/*/Makefile.
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1597 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'pg')
-rwxr-xr-xpg23
1 files changed, 23 insertions, 0 deletions
diff --git a/pg b/pg
new file mode 100755
index 0000000..db6174a
--- /dev/null
+++ b/pg
@@ -0,0 +1,23 @@
+#!/bin/sh
+# Start Proof General with the right -I options
+# Use the Makefile to rebuild dependencies if needed
+# Recompile the modified file after coqide editing
+
+PWD=`pwd`
+ARCH=$PWD/`sed -n -e 's/^ARCH=//p' Makefile.config`
+VARIANT=$ARCH/`sed -n -e 's/^VARIANT=//p' Makefile.config`
+
+
+make -q ${1}o || {
+ make -n ${1}o | grep -v "\\b${1}\\b" | \
+ (while read cmd; do
+ $cmd || exit 2
+ done)
+}
+COQPROGNAME="coqtop"
+COQPROGARGS="\"-I\" \"$PWD/lib\" \"-I\" \"$PWD/common\" \"-I\" \"$VARIANT\" \"-I\" \"$ARCH\" \"-I\" \"$PWD/backend\" \"-I\" \"$PWD/cfrontend\""
+
+
+emacs --eval "(setq coq-prog-name \"$COQPROGNAME\")" \
+ --eval "(setq coq-prog-args '($COQPROGARGS))" $1 \
+&& make ${1}o