summaryrefslogtreecommitdiff
path: root/extraction
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-03-09 13:35:00 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2011-03-09 13:35:00 +0000
commit3ffda353b0d92ccd0ff3693ad0be81531c3c0537 (patch)
tree9a07da4e83919d763086e379de161fd4cfe8ab02 /extraction
parent06c55ab8fa4c0bf59479faf03d30a51c780da36e (diff)
Updated for Coq 8.3pl1. Some cleanups in test/*/Makefile.
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1597 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'extraction')
-rw-r--r--extraction/Kildall.ml.patch21
-rw-r--r--extraction/extraction.v15
-rwxr-xr-xextraction/fixextract4
3 files changed, 8 insertions, 32 deletions
diff --git a/extraction/Kildall.ml.patch b/extraction/Kildall.ml.patch
deleted file mode 100644
index 6c94854..0000000
--- a/extraction/Kildall.ml.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-*** kildall.ml.orig 2009-08-16 15:45:21.000000000 +0200
---- kildall.ml 2009-08-16 15:45:27.000000000 +0200
-***************
-*** 252,259 ****
-
- (** val basic_block_map : positive list PTree.t -> positive -> bbmap **)
-
-! let basic_block_map successors entrypoint x =
-! is_basic_block_head entrypoint (make_predecessors successors) x
-
- (** val basic_block_list :
- positive list PTree.t -> bbmap -> positive list **)
---- 252,259 ----
-
- (** val basic_block_map : positive list PTree.t -> positive -> bbmap **)
-
-! let basic_block_map successors entrypoint =
-! is_basic_block_head entrypoint (make_predecessors successors)
-
- (** val basic_block_list :
- positive list PTree.t -> bbmap -> positive list **)
diff --git a/extraction/extraction.v b/extraction/extraction.v
index 8e3c1aa..1c14298 100644
--- a/extraction/extraction.v
+++ b/extraction/extraction.v
@@ -23,7 +23,7 @@ Extract Inductive unit => "unit" [ "()" ].
Extract Inductive bool => "bool" [ "true" "false" ].
Extract Inductive sumbool => "bool" [ "true" "false" ].
Extract Inductive option => "option" [ "Some" "None" ].
-Extract Inductive List.list => "list" [ "[]" "(::)" ].
+Extract Inductive list => "list" [ "[]" "(::)" ].
(* Float *)
Extract Inlined Constant Floats.float => "float".
@@ -52,6 +52,9 @@ Extract Constant Memdata.big_endian => "Memdataaux.big_endian".
(* Memory - work around an extraction bug. *)
Extraction NoInline Memory.Mem.valid_pointer.
+(* Errors *)
+Extraction Inline Errors.bind Errors.bind2.
+
(* Iteration *)
Extract Constant Iteration.dependent_description' =>
"fun x -> assert false".
@@ -64,6 +67,7 @@ Extract Constant Iteration.GenIter.iterate =>
(* RTLgen *)
Extract Constant RTLgen.compile_switch => "RTLgenaux.compile_switch".
Extract Constant RTLgen.more_likely => "RTLgenaux.more_likely".
+Extraction Inline RTLgen.ret RTLgen.error RTLgen.bind RTLgen.bind2.
(* RTLtyping *)
Extract Constant RTLtyping.infer_type_environment => "RTLtypingaux.infer_type_environment".
@@ -74,6 +78,9 @@ Extract Constant Coloring.graph_coloring => "Coloringaux.graph_coloring".
(* Linearize *)
Extract Constant Linearize.enumerate_aux => "Linearizeaux.enumerate_aux".
+(* SimplExpr *)
+Extraction Inline SimplExpr.ret SimplExpr.error SimplExpr.bind SimplExpr.bind2.
+
(* Compiler *)
Extract Constant Compiler.print_Csyntax => "PrintCsyntax.print_if".
Extract Constant Compiler.print_Clight => "PrintClight.print_if".
@@ -85,12 +92,6 @@ Extract Constant Compiler.print_RTL_constprop => "PrintRTL.print_constprop".
Extract Constant Compiler.print_RTL_cse => "PrintRTL.print_cse".
Extract Constant Compiler.print_LTLin => "PrintLTLin.print_if".
-(* Suppression of stupidly big equality functions *)
-Extract Constant Op.eq_operation => "fun (x: operation) (y: operation) -> x = y".
-Extract Constant Op.eq_addressing => "fun (x: addressing) (y: addressing) -> x = y".
-(*Extract Constant CSE.eq_rhs => "fun (x: rhs) (y: rhs) -> x = y".*)
-Extract Constant Machregs.mreg_eq => "fun (x: mreg) (y: mreg) -> x = y".
-
(* Processor-specific extraction directives *)
Load extractionMachdep.
diff --git a/extraction/fixextract b/extraction/fixextract
deleted file mode 100755
index 86ebdbd..0000000
--- a/extraction/fixextract
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-echo "Patching files..."
-for i in *.patch; do patch < $i; done