summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2012-02-04 19:14:14 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2012-02-04 19:14:14 +0000
commit25b9b003178002360d666919f2e49e7f5f4a36e2 (patch)
treed5f7fb317f34f3a7ac9383c21b0eb143317c30f8 /configure
parent145b32ec504541e98f73b2c87ff2d8181b5e7968 (diff)
Merge of the "volatile" branch:
- native treatment of volatile accesses in CompCert C's semantics - translation of volatile accesses to built-ins in SimplExpr - native treatment of struct assignment and passing struct parameter by value - only passing struct result by value remains emulated - in cparser, remove emulations that are no longer used - added C99's type _Bool and used it to express || and && more efficiently. git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1814 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure b/configure
index da2e59f..9c2618a 100755
--- a/configure
+++ b/configure
@@ -32,6 +32,8 @@ usage='Usage: ./configure [options] target
Supported targets:
ppc-macosx (PowerPC, MacOS X)
ppc-linux (PowerPC, Linux)
+ ppc-eabi-unix (PowerPC, EABI with Unix tools)
+ ppc-eabi-diab (PowerPC, EABI with Diab tools)
arm-linux (ARM, Linux EABI)
ia32-linux (x86 32 bits, Linux)
ia32-bsd (x86 32 bits, BSD)
@@ -76,7 +78,7 @@ case "$target" in
clinker="gcc -arch ppc"
libmath=""
need_stdlib_wrapper="true";;
- powerpc-linux|ppc-linux)
+ powerpc-linux|ppc-linux|powerpc-eabi-unix|ppc-eabi-unix)
arch="powerpc"
variant="eabi"
system="linux"
@@ -86,6 +88,16 @@ case "$target" in
clinker="gcc"
libmath="-lm"
need_stdlib_wrapper="false";;
+ powerpc-eabi-diab|ppc-eabi-diab)
+ arch="powerpc"
+ variant="eabi"
+ system="diab"
+ cc="dcc"
+ cprepro="dcc -E"
+ casm="das"
+ clinker="dcc"
+ libmath="-lm"
+ need_stdlib_wrapper="false";;
arm-linux)
arch="arm"
variant="linux"
@@ -227,7 +239,7 @@ fi
if test "$target" = "manual"; then
cat <<EOF
-Please finish the configuration by editing file ./Makefile.config
+Please finish the configuration by editing file ./Makefile.config.
EOF
@@ -251,6 +263,8 @@ CompCert configuration:
Binaries installed in......... $bindirexp
Library files installed in.... $libdirexp
+If anything above looks wrong, please edit file ./Makefile.config to correct.
+
EOF
fi