summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2012-12-31 15:56:53 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2012-12-31 15:56:53 +0000
commite72c8c4319e485d8e39c9ce085d21711fe781fed (patch)
treecdd3050fdedb77466636b66fcd3d3fe01d039baf /Makefile
parent5bf13140754a55599ae27942b17cdbb4b7ed74e9 (diff)
RTLgenaux: heuristic to orient if-then-else statements based on sizes.
Makefile: coqchk notes git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2086 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index b4df0d4..716116c 100644
--- a/Makefile
+++ b/Makefile
@@ -241,11 +241,13 @@ distclean:
check-admitted: $(FILES)
@grep -w 'admit\|Admitted\|ADMITTED' $^ || echo "Nothing admitted."
-# Problems with coqchk:
+# Problems with coqchk (coq 8.3pl3):
# Integers.one_bits_range takes forever to check
# Mach#<>#instruction causes a failure
+# Asm#<>#instruction causes a failure
+# UnionFind.UF.elt causes an Anomaly (!)
check-proof: $(FILES)
- $(COQCHK) -admit Integers Complements
+ $(COQCHK) -admit Integers -admit Mach -admit Asm -admit UnionFind Complements
include .depend