summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2012-03-28 13:32:21 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2012-03-28 13:32:21 +0000
commitbefbc76f89f3d8abc8da17caf91ea4a87ec96eeb (patch)
treed84d76258ca9b2505713552bb62be8c40714787b /Makefile
parent26c166e279ec05837b6b3b5db80a7ef3c520db32 (diff)
checklink: first import of Valentin Robert's validator for asm and link
cparser: renamed Errors to Cerrors; removed packing into Cparser. git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1856 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 2e531c5..00f8571 100644
--- a/Makefile
+++ b/Makefile
@@ -27,7 +27,11 @@ OCB_OPTIONS=\
-j 2 \
-no-hygiene \
-no-links \
- -I extraction $(INCLUDES)
+ -I extraction -I cparser $(INCLUDES)
+OCB_OPTIONS_CHECKLINK=\
+ $(OCB_OPTIONS) \
+ -I checklink \
+ -use-ocamlfind
VPATH=$(DIRS)
GPATH=$(DIRS)
@@ -114,7 +118,15 @@ ccomp.byte: driver/Configuration.ml
runtime:
$(MAKE) -C runtime
-.PHONY: proof extraction cil ccomp ccomp.prof ccomp.byte cinterp cinterp.byte runtime
+cchecklink: driver/Configuration.ml
+ $(OCAMLBUILD) $(OCB_OPTIONS_CHECKLINK) Validator.native \
+ && rm -f cchecklink && $(SLN) _build/checklink/Validator.native cchecklink
+
+cchecklink.byte: driver/Configuration.ml
+ $(OCAMLBUILD) $(OCB_OPTIONS_CHECKLINK) Validator.d.byte \
+ && rm -f cchecklink.byte && $(SLN) _build/checklink/Validator.d.byte cchecklink.byte
+
+.PHONY: proof extraction cil ccomp ccomp.prof ccomp.byte runtime cchecklink cchecklink.byte
all:
$(MAKE) proof
@@ -152,7 +164,7 @@ latexdoc:
@tools/ndfun $*.vp > $*.v || { rm -f $*.v; exit 2; }
@chmod -w $*.v
-driver/Configuration.ml: Makefile.config
+driver/Configuration.ml: Makefile.config VERSION
(echo let stdlib_path = "\"$(LIBDIR)\""; \
echo let prepro = "\"$(CPREPRO)\""; \
echo let asm = "\"$(CASM)\""; \
@@ -160,7 +172,9 @@ driver/Configuration.ml: Makefile.config
echo let arch = "\"$(ARCH)\""; \
echo let variant = "\"$(VARIANT)\""; \
echo let system = "\"$(SYSTEM)\""; \
- echo let need_stdlib_wrapper = $(NEED_STDLIB_WRAPPER)) \
+ echo let need_stdlib_wrapper = $(NEED_STDLIB_WRAPPER); \
+ version=`cat VERSION`; \
+ echo let version = "\"$$version\"") \
> driver/Configuration.ml
depend: $(FILES)