summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2007-08-06 08:45:25 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2007-08-06 08:45:25 +0000
commit94aea0609bb54f0fde29a558366b646b3b8d21a2 (patch)
tree2c81bb38c04b6ca50dd8588681fe68baa71a237a /Makefile
parentc0bc146622528e3d52534909f5ae5cd2e375da8f (diff)
Ajout et utilisation de caml/Driver.ml. Ajout ./configure. Revu Makefiles
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@387 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index bea28ac..f54d7c4 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,8 @@
+include Makefile.config
+
COQC=coqc $(INCLUDES)
COQDEP=coqdep $(INCLUDES)
COQDOC=coqdoc
-CILDISTRIB=cil-1.3.5.tar.gz
INCLUDES=-I lib -I common -I backend -I cfrontend
@@ -55,16 +56,11 @@ proof: $(FILES:.v=.vo)
all:
$(MAKE) proof
- $(MAKE) cil
+ $(MAKE) -C cil
$(MAKE) -C extraction extraction
$(MAKE) -C extraction depend
$(MAKE) -C extraction
-
-cil:
- tar xzf $(CILDISTRIB)
- for i in cil.patch/*; do patch -p1 < $$i; done
- cd cil; ./configure
- $(MAKE) -C cil
+ $(MAKE) -C runtime
documentation:
@ln -f $(FILES) doc/
@@ -88,11 +84,22 @@ latexdoc:
depend:
$(COQDEP) $(FILES) > .depend
+install:
+ $(MAKE) -C extraction install
+ $(MAKE) -C runtime install
+
clean:
rm -f */*.vo *~ */*~
rm -rf doc/html doc/*.glob
$(MAKE) -C extraction clean
+ $(MAKE) -C runtime clean
$(MAKE) -C test/cminor clean
+ $(MAKE) -C test/c clean
+
+distclean:
+ $(MAKE) clean
+ rm -rf cil
+ rm -f Makefile.config
include .depend