diff options
author | xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e> | 2014-07-29 13:42:11 +0000 |
---|---|---|
committer | xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e> | 2014-07-29 13:42:11 +0000 |
commit | 769589fb4f72edf46c16a396de6777d8e2fbb9bf (patch) | |
tree | 433505a6dba47631170d815945d2782bbc56a264 /Makefile | |
parent | 21e269ee37b934428306f53dda0495fee30dd8fa (diff) |
configure: distinguish between ABI and processor model.
ARM: various tweaks, incl. support for SDIV and UDIV insns when available.
test/regression/funptr2.c: Thumb does weird things with <function ptr>+1.
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2555 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -226,7 +226,8 @@ driver/Configuration.ml: Makefile.config VERSION echo let asm = "\"$(CASM)\""; \ echo let linker = "\"$(CLINKER)\""; \ echo let arch = "\"$(ARCH)\""; \ - echo let variant = "\"$(VARIANT)\""; \ + echo let model = "\"$(MODEL)\""; \ + echo let abi = "\"$(ABI)\""; \ echo let system = "\"$(SYSTEM)\""; \ echo let has_runtime_lib = $(HAS_RUNTIME_LIB); \ echo let asm_supports_cfi = $(ASM_SUPPORTS_CFI); \ |