summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-01-08 09:55:23 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-01-08 09:55:23 +0000
commit595c1e185778601e7231705e76cb502448327c5f (patch)
tree6465f899b756b9c5d25e9c3b6f06dd56319c70d5 /Makefile
parent0899bd69f402eb68d55297afe7131dbc539b693a (diff)
More correct exportclight/ dependencies
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2094 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 9e04d95..4992098 100644
--- a/Makefile
+++ b/Makefile
@@ -210,7 +210,7 @@ driver/Configuration.ml: Makefile.config VERSION
echo let version = "\"$$version\"") \
> driver/Configuration.ml
-depend: $(FILES)
+depend: $(FILES) exportclight/Clightdefs.v
$(COQDEP) $^ \
| sed -e 's|$(ARCH)/$(VARIANT)/|$$(ARCH)/$$(VARIANT)/|g' \
-e 's|$(ARCH)/|$$(ARCH)/|g' \
@@ -225,7 +225,7 @@ endif
$(MAKE) -C runtime install
clean:
- rm -f $(patsubst %, %/*.vo, $(DIRS) exportclight)
+ rm -f $(patsubst %, %/*.vo, $(DIRS))
rm -f ccomp ccomp.byte cchecklink cchecklink.byte clightgen clightgen.byte
rm -rf _build
rm -rf doc/html doc/*.glob