summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2006-09-07 15:30:24 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2006-09-07 15:30:24 +0000
commit593ce3f7c5647e284cd2fdc3dd3ed41be9563982 (patch)
tree6ec1df325b89bb0c320023861118549deb9a9e71 /Makefile
parentfa7415be2fe9b240374f0a51c1cd4a9de5376c5a (diff)
Integration du front-end CIL developpe par Thomas Moniot
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@84 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 4a24808..51e2fa2 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
COQC=coqc $(INCLUDES)
COQDEP=coqdep $(INCLUDES)
COQDOC=coqdoc
+CILDISTRIB=cil-1.3.5.tar.gz
INCLUDES=-I lib -I common -I backend -I cfrontend
@@ -52,10 +53,17 @@ proof: $(FILES:.v=.vo)
all:
$(MAKE) proof
+ $(MAKE) cil
$(MAKE) -C extraction extraction
$(MAKE) -C extraction depend
$(MAKE) -C extraction
+cil:
+ tar xzf $(CILDISTRIB)
+ for i in cil.patch/*; do patch -p1 < $$i; done
+ cd cil; ./configure
+ $(MAKE) -C cil
+
documentation:
$(COQDOC) --html -d doc $(FLATFILES:%.v=--glob-from doc/%.glob) $(FILES)
doc/removeproofs doc/lib.*.html doc/backend.*.html