summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2012-04-04 13:59:24 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2012-04-04 13:59:24 +0000
commit547d8ecb50541db1e80bb23d065e55046a27452e (patch)
treebe98037869440d20983b85ec7f70b3b0706d2880 /Makefile
parent5a5d16abc786834f5e4f1bfe6412a17900c22ef5 (diff)
Configuration, build and install for cchecklink. Clean-ups in myocamlbuild.ml.
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1874 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 00f8571..2c2825c 100644
--- a/Makefile
+++ b/Makefile
@@ -133,6 +133,9 @@ all:
$(MAKE) extraction
$(MAKE) ccomp
$(MAKE) runtime
+ifeq ($(CCHECKLINK),true)
+ $(MAKE) cchecklink
+endif
documentation: doc/coq2html $(FILES)
mkdir -p doc/html
@@ -186,11 +189,14 @@ depend: $(FILES)
install:
install -d $(BINDIR)
install ./ccomp $(BINDIR)
+ifeq ($(CCHECKLINK),true)
+ install ./cchecklink $(BINDIR)
+endif
$(MAKE) -C runtime install
clean:
rm -f $(patsubst %, %/*.vo, $(DIRS))
- rm -f ccomp ccomp.byte
+ rm -f ccomp ccomp.byte cchecklink cchecklink.byte
rm -rf _build
rm -rf doc/html doc/*.glob
rm -f doc/coq2html.ml doc/coq2html