summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2014-04-11 13:45:43 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2014-04-11 13:45:43 +0000
commit0b927a1f21a6a0b7c2d8ef99457b2d5c32ca181d (patch)
treeeed1e2c6e19f2ec54074f39008463779708c6801 /Makefile
parent336a1f906a9c617e68e9d43e244bf42e9bdbae64 (diff)
ia32/Select*: complete the modifications to shifts.
Makefile: missing "clean" actions. Makefile/pg/coq: honor $COQBIN if set (as suggested by P. Boutillier) to facilitate testing with different Coq versions. git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2453 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 87a4977..7c0681a 100644
--- a/Makefile
+++ b/Makefile
@@ -26,11 +26,11 @@ COQINCLUDES=$(foreach d, $(RECDIRS), -R $(d) -as compcert.$(d)) \
CAMLINCLUDES=$(patsubst %,-I %, $(DIRS)) -I extraction -I cparser
-COQC=coqc -q $(COQINCLUDES)
-COQDEP=coqdep $(COQINCLUDES)
-COQDOC=coqdoc
-COQEXEC=coqtop $(COQINCLUDES) -batch -load-vernac-source
-COQCHK=coqchk $(COQINCLUDES)
+COQC="$(COQBIN)coqc" -q $(COQINCLUDES)
+COQDEP="$(COQBIN)coqdep" $(COQINCLUDES)
+COQDOC="$(COQBIN)coqdoc"
+COQEXEC="$(COQBIN)coqtop" $(COQINCLUDES) -batch -load-vernac-source
+COQCHK="$(COQBIN)coqchk" $(COQINCLUDES)
OCAMLBUILD=ocamlbuild
OCB_OPTIONS=\
@@ -243,10 +243,11 @@ clean:
rm -f ccomp ccomp.byte cchecklink cchecklink.byte clightgen clightgen.byte
rm -rf _build
rm -rf doc/html doc/*.glob
- rm -f doc/coq2html.ml doc/coq2html
+ rm -f doc/coq2html.ml doc/coq2html doc/*.cm? doc/*.o
rm -f driver/Configuration.ml
rm -f extraction/STAMP extraction/*.ml extraction/*.mli
- rm -f tools/ndfun
+ rm -f tools/ndfun tools/*.cm? tools/*.o
+ rm -f $(ARCH)/ConstpropOp.v $(ARCH)/SelectOp.v backend/SelectDiv.v backend/SelectLong.v
$(MAKE) -C runtime clean
$(MAKE) -C test clean