summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGravatar blazy <blazy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2012-07-04 16:26:51 +0000
committerGravatar blazy <blazy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2012-07-04 16:26:51 +0000
commit05f9369c759ecd957585feec6659e3c05e313a11 (patch)
treea5754d07e1c74af1dcd1e886bae3988647bc7f98 /Makefile
parent7155843b75086379eeaeaa6c89c824aebd58104e (diff)
Ajout trunk CompCert
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@1955 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 175f773..0615215 100644
--- a/Makefile
+++ b/Makefile
@@ -17,10 +17,10 @@ DIRS=lib common $(ARCH)/$(VARIANT) $(ARCH) backend cfrontend driver \
INCLUDES=$(patsubst %,-I %, $(DIRS))
-COQC=coqc -q $(INCLUDES)
-COQDEP=coqdep $(INCLUDES)
-COQDOC=coqdoc
-COQEXEC=coqtop $(INCLUDES) -batch -load-vernac-source
+COQC=/usr/local/bin/coqc -q $(INCLUDES)
+COQDEP=/usr/local/bin/coqdep $(INCLUDES)
+COQDOC=/usr/local/bin/coqdoc
+COQEXEC=/usr/local/bin/coqtop $(INCLUDES) -batch -load-vernac-source
COQCHK=coqchk $(INCLUDES)
OCAMLBUILD=ocamlbuild
@@ -86,14 +86,14 @@ BACKEND=\
Mach.v Machtyping.v \
Bounds.v Stacklayout.v Stacking.v Stackingproof.v Stackingtyping.v \
Machsem.v \
- Asm.v Asmgen.v Asmgenretaddr.v Asmgenproof1.v Asmgenproof.v
+ Asm.v Asmgen.v Asmgenretaddr.v Asmgenproof1.v Asmgenproof.v
# C front-end modules (in cfrontend/)
CFRONTEND=Csyntax.v Csem.v Cstrategy.v Cexec.v \
Initializers.v Initializersproof.v \
SimplExpr.v SimplExprspec.v SimplExprproof.v \
- Clight.v Cshmgen.v Cshmgenproof.v \
+ Clight.v Cshmgen.v Cshmgenproof.v \
Csharpminor.v Cminorgen.v Cminorgenproof.v
# Putting everything together (in driver/)