summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2015-02-05 19:07:50 -0500
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2015-02-05 21:43:10 -0500
commitcb05177c2e72010803aa36653153dfb4a67615e0 (patch)
tree5cf3f36f88c7bfac528abce7bb754b28a7d101fa
parent3297edd971b6272081925a53c6bd4a9d960eac56 (diff)
Pass target to configure
The CompCert configure script isn’t a standard configure script: It takes a positional argument specifying the architecture it should target. Override dh_auto_configure to do nothing, and pass the relevant arguments to configure in dh_auto_build.
-rwxr-xr-xdebian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 15d9ca3..fd43eb3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,16 @@ override_dh_auto_clean:
touch Makefile.config
dh_auto_clean
+.PHONY: override_dh_auto_configure
+override_dh_auto_configure:
+ /bin/true
+
+.PHONY: override_dh_auto_build
+override_dh_auto_build:
+ ./configure \
+ -prefix /usr -libdir /usr/lib/$(DEB_HOST_MULTIARCH) ia32-linux
+ dh_auto_build
+
.PHONY: override_dh_builddeb
override_dh_builddeb:
dh_builddeb -- -Zxz -z9