summaryrefslogtreecommitdiff
path: root/Test/Makefile
diff options
context:
space:
mode:
authorGravatar MichalMoskal <unknown>2009-12-17 01:12:56 +0000
committerGravatar MichalMoskal <unknown>2009-12-17 01:12:56 +0000
commitfa8cb4c335668f180fa2c181ca6bb1ad87b54c4a (patch)
tree196fd3c1d78ed3c4c7cd7516ab5c6a7e7a01e8ca /Test/Makefile
parent493f1758d8ba70ead41c6951b5dfa223032ac83c (diff)
Add makefile for running tests, allows "make -j4" to utilize multiple cores.
Change the runtest.bat to report the testname in "succeeded/failed" message, so one can make sense of the multiple core output.
Diffstat (limited to 'Test/Makefile')
-rw-r--r--Test/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Test/Makefile b/Test/Makefile
new file mode 100644
index 00000000..dab13bd2
--- /dev/null
+++ b/Test/Makefile
@@ -0,0 +1,17 @@
+TESTS_FILE = alltests.txt
+LONG = $(shell awk '{ if (tolower($$2) ~ /^long$$/) print $$1 }' $(TESTS_FILE))
+NORMAL = $(shell awk '{ if (tolower($$2) ~ /^use$$/) print $$1 }' $(TESTS_FILE))
+TESTS = $(NORMAL)
+
+all: $(addprefix run-, $(TESTS))
+ @echo ALL OK
+
+
+show:
+ @echo $(TESTS)
+
+long:
+ $(MAKE) TESTS="$(NORMAL) $(LONG)" all
+
+run-%:
+ @./runtest.bat $*