summaryrefslogtreecommitdiff
path: root/Source/Dafny/Makefile
diff options
context:
space:
mode:
authorGravatar mikebarnett <unknown>2010-06-22 17:58:58 +0000
committerGravatar mikebarnett <unknown>2010-06-22 17:58:58 +0000
commit67c07706d2b4ee941954301a0c18abfcf253384c (patch)
tree994d3e772c2fce65605bd28b947ed7f2ede9d00a /Source/Dafny/Makefile
parent98ee7b446b22df255ecf914d68f1997ea987877e (diff)
Updated the frame files to work with the latest Coco/R. This entails *not* having them in this repository because of license issues. Instead, they must be downloaded from http://boogiepartners.codeplex.com/ and then copied into the appropriate directories.
Lots of code changes to compensate for the new frame files.
Diffstat (limited to 'Source/Dafny/Makefile')
-rw-r--r--Source/Dafny/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Source/Dafny/Makefile b/Source/Dafny/Makefile
index fd2141b3..e545fbae 100644
--- a/Source/Dafny/Makefile
+++ b/Source/Dafny/Makefile
@@ -1,13 +1,18 @@
COCO = ..\..\Binaries\Coco.exe
ASML = ..\..\Binaries\asmlc.boot.exe
+# ###############################################################################
+# The frame files are no longer in this directory. They must be downloaded
+# from http://boogiepartners.codeplex.com/ and then copied into this directory.
+# ###############################################################################
+
# "all" depends on 2 files, really (Parser.cs and Scanner.cs), but they
# are both generated in one go and I don't know a better way to tell
# nmake that. --KRML
all: Parser.ssc
Parser.ssc: Scanner.frame Parser.frame Dafny.atg
- $(COCO) Dafny.atg
+ $(COCO) Dafny.atg -namespace Microsoft.Dafny
copy Parser.cs Parser.ssc
copy Scanner.cs Scanner.ssc