summaryrefslogtreecommitdiff
path: root/Chalice/Makefile
diff options
context:
space:
mode:
authorGravatar rustanleino <unknown>2009-08-06 00:50:11 +0000
committerGravatar rustanleino <unknown>2009-08-06 00:50:11 +0000
commit9f23f2630a7ed9bd51965f739e00629997318489 (patch)
tree31a8c1d63c303c36a3381cc3fe5d186f07b2f9d4 /Chalice/Makefile
parent6b92a6945ec518a17865847d0ff6a6c251c72ee9 (diff)
Made Makefile DOS friendly.
Diffstat (limited to 'Chalice/Makefile')
-rw-r--r--Chalice/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/Chalice/Makefile b/Chalice/Makefile
index a0edde9b..2a9f17c1 100644
--- a/Chalice/Makefile
+++ b/Chalice/Makefile
@@ -5,22 +5,17 @@ SCALA = scala
CLASS_DIR = bin
SRC_DIR = src
+SOURCES = $(SRC_DIR)/*.scala
-all: $(CLASS_DIR)/Chalice.class
-SOURCES = $(SRC_DIR)/*.scala
+all: $(CLASS_DIR)/Chalice.class
$(CLASS_DIR)/Chalice.class: $(SOURCES)
IF NOT EXIST $(CLASS_DIR) MKDIR $(CLASS_DIR)
$(SCALAC) -d $(CLASS_DIR) -unchecked $(SOURCES)
clean:
- rm -f $(CLASS_DIR)/*.class
+ del $(CLASS_DIR)\*.class
RUN_CHALICE = $(SCALA) -cp $(CLASS_DIR) -unchecked Chalice
-RUN_BOOGIE = ..\Binaries\boogie.exe
test: $(RUN_CHALICE) examples\cell.chalice > examples\results\cell.chalice.expected
-
-try: $(CLASS_DIR)/Chalice.class
- $(RUN_CHALICE) prog3.chalice > prog3.bpl
- $(RUN_BOOGIE) prog3.bpl /smoke