summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index c6c94e3c..859e20ba 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,12 +24,15 @@ override_dh_auto_clean:
override_dh_auto_configure:
dh_auto_configure -Bstatic -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=OFF
- dh_auto_configure -Bshared -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=ON
+ dh_auto_configure -Bshared -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=ON -DABSL_RUN_TESTS=ON -DABSL_USE_GOOGLETEST_HEAD=OFF
override_dh_auto_build:
dh_auto_build -Bstatic
dh_auto_build -Bshared
+override_dh_auto_test:
+ dh_auto_test -Bshared
+
override_dh_auto_install:
dh_auto_install -Bstatic
dh_auto_install -Bshared