summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 11 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index a20f22b8..03e1a00d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,13 +15,11 @@
export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow reproducible=+fixfilepath
-# Some of the Abseil tests exhaust virtual memory on our mipsel buildds.
-# TODO(bbaren): Key this off available virtual memory rather than a particular
-# architecture.
-ifeq ($(shell dpkg-architecture -qDEB_HOST_ARCH),mipsel)
-ABSL_RUN_TESTS=OFF
-else
+# Unit tests aren't working on all platforms yet.
+ifeq ($(shell dpkg-architecture -qDEB_HOST_ARCH),amd64)
ABSL_RUN_TESTS=ON
+else
+ABSL_RUN_TESTS=OFF
endif
%:
@@ -33,14 +31,20 @@ override_dh_auto_clean:
override_dh_auto_configure:
dh_auto_configure -Bstatic -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=OFF
- dh_auto_configure -Bshared -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=ON -DABSL_RUN_TESTS=$ABSL_RUN_TESTS -DABSL_USE_GOOGLETEST_HEAD=OFF
+ifeq ($(ABSL_RUN_TESTS),ON)
+ dh_auto_configure -Bshared -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=ON -DABSL_RUN_TESTS=ON -DABSL_USE_GOOGLETEST_HEAD=OFF
+else
+ dh_auto_configure -Bshared -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=ON
+endif
override_dh_auto_build:
dh_auto_build -Bstatic
dh_auto_build -Bshared
+ifeq ($(ABSL_RUN_TESTS),ON)
override_dh_auto_test:
dh_auto_test -Bshared
+endif
override_dh_auto_install:
dh_auto_install -Bstatic