summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 12 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 4c276263..ed4e354a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,9 +18,19 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow
%:
dh $@
+override_dh_auto_clean:
+ $(RM) -r $(CURDIR)/static
+ $(RM) -r $(CURDIR)/shared
+
override_dh_auto_configure:
- dh_auto_configure -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=ON
+ dh_auto_configure -Bstatic -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=OFF
+ dh_auto_configure -Bshared -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=ON
+
+override_dh_auto_build:
+ dh_auto_build -Bstatic
+ dh_auto_build -Bshared
override_dh_auto_install:
- dh_auto_install
+ dh_auto_install -Bstatic
+ dh_auto_install -Bshared
find debian/tmp -type d -empty -delete