summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 1 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 4a36943e..16d92626 100755
--- a/debian/rules
+++ b/debian/rules
@@ -44,12 +44,8 @@ override_dh_auto_clean:
$(RM) -r $(CURDIR)/shared
override_dh_auto_configure:
- dh_auto_configure -Bstatic -- -DCMAKE_CXX_STANDARD=17 -DBUILD_SHARED_LIBS=OFF
-ifeq ($(ABSL_RUN_TESTS),ON)
- dh_auto_configure -Bshared -- -DCMAKE_CXX_STANDARD=17 -DBUILD_SHARED_LIBS=ON -DBUILD_TESTING=ON -DABSL_BUILD_TESTING=ON -DABSL_USE_GOOGLETEST_HEAD=OFF
-else
+ dh_auto_configure -Bstatic -- -DCMAKE_CXX_STANDARD=17 -DBUILD_SHARED_LIBS=OFF -DBUILD_TESTING=ON -DABSL_BUILD_TESTING=ON -DABSL_USE_GOOGLETEST_HEAD=OFF
dh_auto_configure -Bshared -- -DCMAKE_CXX_STANDARD=17 -DBUILD_SHARED_LIBS=ON
-endif
override_dh_auto_build:
dh_auto_build -Bstatic