summaryrefslogtreecommitdiff
path: root/absl
diff options
context:
space:
mode:
Diffstat (limited to 'absl')
-rw-r--r--absl/base/BUILD.bazel1
-rw-r--r--absl/base/CMakeLists.txt23
-rw-r--r--absl/debugging/BUILD.bazel1
-rw-r--r--absl/hash/hash.h2
-rw-r--r--absl/types/BUILD.bazel1
5 files changed, 26 insertions, 2 deletions
diff --git a/absl/base/BUILD.bazel b/absl/base/BUILD.bazel
index f7d81013..9b86ce77 100644
--- a/absl/base/BUILD.bazel
+++ b/absl/base/BUILD.bazel
@@ -75,7 +75,6 @@ cc_library(
copts = ABSL_DEFAULT_COPTS,
deps = [
":config",
- ":dynamic_annotations",
],
)
diff --git a/absl/base/CMakeLists.txt b/absl/base/CMakeLists.txt
index 202003e6..3c580d43 100644
--- a/absl/base/CMakeLists.txt
+++ b/absl/base/CMakeLists.txt
@@ -130,6 +130,29 @@ absl_library(
absl_cc_library(
NAME
+ config
+ HDRS
+ "config.h"
+ "policy_checks.h"
+ PUBLIC
+)
+
+absl_cc_library(
+ NAME
+ core_headers
+ HDRS
+ "attributes.h"
+ "macros.h"
+ "optimization.h"
+ "port.h"
+ "thread_annotations.h"
+ DEPS
+ absl::config
+ PUBLIC
+)
+
+absl_cc_library(
+ NAME
spinlock_wait
SRCS
"internal/spinlock_wait.cc"
diff --git a/absl/debugging/BUILD.bazel b/absl/debugging/BUILD.bazel
index e1e7fced..a8ebaea4 100644
--- a/absl/debugging/BUILD.bazel
+++ b/absl/debugging/BUILD.bazel
@@ -149,6 +149,7 @@ cc_library(
copts = ABSL_DEFAULT_COPTS,
deps = [
"//absl/base",
+ "//absl/base:core_headers",
"//absl/base:dynamic_annotations",
],
)
diff --git a/absl/hash/hash.h b/absl/hash/hash.h
index 8cbb19e2..36c7c2b3 100644
--- a/absl/hash/hash.h
+++ b/absl/hash/hash.h
@@ -98,7 +98,7 @@ namespace absl {
// * absl::string_view
// * absl::InlinedVector
// * absl::FixedArray
-// * absl::unit128
+// * absl::uint128
// * absl::Time, absl::Duration, and absl::TimeZone
//
// Note: the list above is not meant to be exhaustive. Additional type support
diff --git a/absl/types/BUILD.bazel b/absl/types/BUILD.bazel
index 32f690c9..43899ca7 100644
--- a/absl/types/BUILD.bazel
+++ b/absl/types/BUILD.bazel
@@ -168,6 +168,7 @@ cc_library(
deps = [
":bad_optional_access",
"//absl/base:config",
+ "//absl/base:core_headers",
"//absl/memory",
"//absl/meta:type_traits",
"//absl/utility",