summaryrefslogtreecommitdiff
path: root/absl/time/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'absl/time/CMakeLists.txt')
-rw-r--r--absl/time/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/absl/time/CMakeLists.txt b/absl/time/CMakeLists.txt
index 7b720540..e1ade7a3 100644
--- a/absl/time/CMakeLists.txt
+++ b/absl/time/CMakeLists.txt
@@ -54,10 +54,6 @@ absl_cc_library(
${ABSL_DEFAULT_COPTS}
)
-if(APPLE)
- find_library(CoreFoundation CoreFoundation)
-endif()
-
absl_cc_library(
NAME
time_zone
@@ -84,7 +80,10 @@ absl_cc_library(
COPTS
${ABSL_DEFAULT_COPTS}
DEPS
- $<$<PLATFORM_ID:Darwin>:${CoreFoundation}>
+ Threads::Threads
+ # TODO(#1495): Use $<LINK_LIBRARY:FRAMEWORK,CoreFoundation> once our
+ # minimum CMake version >= 3.24
+ $<$<PLATFORM_ID:Darwin>:-Wl,-framework,CoreFoundation>
)
# Internal-only target, do not depend on directly.
@@ -122,6 +121,8 @@ absl_cc_test(
absl::time
absl::config
absl::core_headers
+ absl::strings
+ absl::str_format
absl::time_zone
GTest::gmock_main
)