summaryrefslogtreecommitdiff
path: root/absl/memory
diff options
context:
space:
mode:
Diffstat (limited to 'absl/memory')
-rw-r--r--absl/memory/BUILD.bazel14
-rw-r--r--absl/memory/CMakeLists.txt19
-rw-r--r--absl/memory/memory.h2
-rw-r--r--absl/memory/memory_exception_safety_test.cc51
4 files changed, 86 insertions, 0 deletions
diff --git a/absl/memory/BUILD.bazel b/absl/memory/BUILD.bazel
index d5c62265..46f47b12 100644
--- a/absl/memory/BUILD.bazel
+++ b/absl/memory/BUILD.bazel
@@ -18,6 +18,7 @@ load(
"//absl:copts.bzl",
"ABSL_DEFAULT_COPTS",
"ABSL_TEST_COPTS",
+ "ABSL_EXCEPTIONS_FLAG",
)
package(default_visibility = ["//visibility:public"])
@@ -45,3 +46,16 @@ cc_test(
"@com_google_googletest//:gtest_main",
],
)
+
+cc_test(
+ name = "memory_exception_safety_test",
+ srcs = [
+ "memory_exception_safety_test.cc",
+ ],
+ copts = ABSL_TEST_COPTS + ABSL_EXCEPTIONS_FLAG,
+ deps = [
+ ":memory",
+ "//absl/base:exception_safety_testing",
+ "@com_google_googletest//:gtest_main",
+ ],
+)
diff --git a/absl/memory/CMakeLists.txt b/absl/memory/CMakeLists.txt
index 21bfc87e..5958f5c5 100644
--- a/absl/memory/CMakeLists.txt
+++ b/absl/memory/CMakeLists.txt
@@ -49,4 +49,23 @@ absl_test(
)
+# test memory_exception_safety_test
+set(MEMORY_EXCEPTION_SAFETY_TEST_SRC "memory_exception_safety_test.cc")
+set(MEMORY_EXCEPTION_SAFETY_TEST_PUBLIC_LIBRARIES
+ absl::memory
+ absl_base_internal_exception_safety_testing
+)
+
+absl_test(
+ TARGET
+ memory_exception_safety_test
+ SOURCES
+ ${MEMORY_EXCEPTION_SAFETY_TEST_SRC}
+ PUBLIC_LIBRARIES
+ ${MEMORY_EXCEPTION_SAFETY_TEST_PUBLIC_LIBRARIES}
+ PRIVATE_COMPILE_FLAGS
+ ${ABSL_EXCEPTIONS_FLAG}
+)
+
+
diff --git a/absl/memory/memory.h b/absl/memory/memory.h
index cd818cff..54ff2182 100644
--- a/absl/memory/memory.h
+++ b/absl/memory/memory.h
@@ -34,6 +34,7 @@
#include "absl/meta/type_traits.h"
namespace absl {
+inline namespace lts_2018_06_20 {
// -----------------------------------------------------------------------------
// Function Template: WrapUnique()
@@ -636,6 +637,7 @@ struct default_allocator_is_nothrow : std::true_type {};
struct default_allocator_is_nothrow : std::false_type {};
#endif
+} // inline namespace lts_2018_06_20
} // namespace absl
#endif // ABSL_MEMORY_MEMORY_H_
diff --git a/absl/memory/memory_exception_safety_test.cc b/absl/memory/memory_exception_safety_test.cc
new file mode 100644
index 00000000..dc00f349
--- /dev/null
+++ b/absl/memory/memory_exception_safety_test.cc
@@ -0,0 +1,51 @@
+// Copyright 2018 The Abseil Authors.
+//
+// Licensed under the Apache License, Version 2.0 (the "License");
+// you may not use this file except in compliance with the License.
+// You may obtain a copy of the License at
+//
+// http://www.apache.org/licenses/LICENSE-2.0
+//
+// Unless required by applicable law or agreed to in writing, software
+// distributed under the License is distributed on an "AS IS" BASIS,
+// WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+// See the License for the specific language governing permissions and
+// limitations under the License.
+
+#include "absl/memory/memory.h"
+
+#include "gtest/gtest.h"
+#include "absl/base/internal/exception_safety_testing.h"
+
+namespace absl {
+inline namespace lts_2018_06_20 {
+namespace {
+
+using Thrower = ::testing::ThrowingValue<>;
+
+TEST(MakeUnique, CheckForLeaks) {
+ constexpr int kValue = 321;
+ constexpr size_t kLength = 10;
+ auto tester = testing::MakeExceptionSafetyTester()
+ .WithInitialValue(Thrower(kValue))
+ // Ensures make_unique does not modify the input. The real
+ // test, though, is ConstructorTracker checking for leaks.
+ .WithInvariants(testing::strong_guarantee);
+
+ EXPECT_TRUE(tester.Test([](Thrower* thrower) {
+ static_cast<void>(absl::make_unique<Thrower>(*thrower));
+ }));
+
+ EXPECT_TRUE(tester.Test([](Thrower* thrower) {
+ static_cast<void>(absl::make_unique<Thrower>(std::move(*thrower)));
+ }));
+
+ // Test T[n] overload
+ EXPECT_TRUE(tester.Test([&](Thrower*) {
+ static_cast<void>(absl::make_unique<Thrower[]>(kLength));
+ }));
+}
+
+} // namespace
+} // inline namespace lts_2018_06_20
+} // namespace absl