summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 14 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad55fa47..dff46f91 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -86,18 +86,6 @@ if(${ABSL_RUN_TESTS})
enable_testing()
endif()
-# absl:lts-remove-begin(system installation is supported for LTS releases)
-# We don't support system-wide installation
-list(APPEND SYSTEM_INSTALL_DIRS "/usr/local" "/usr" "/opt/" "/opt/local" "c:/Program Files/${PROJECT_NAME}")
-if(NOT DEFINED CMAKE_INSTALL_PREFIX OR CMAKE_INSTALL_PREFIX IN_LIST SYSTEM_INSTALL_DIRS)
- message(WARNING "\
-The default and system-level install directories are unsupported except in LTS \
-releases of Abseil. Please set CMAKE_INSTALL_PREFIX to install Abseil in your \
-source or build tree directly.\
- ")
-endif()
-# absl:lts-remove-end
-
## check targets
if(BUILD_TESTING)
@@ -121,7 +109,19 @@ endif()
add_subdirectory(absl)
-if (ABSL_ENABLE_INSTALL)
+if(ABSL_ENABLE_INSTALL)
+ # absl:lts-remove-begin(system installation is supported for LTS releases)
+ # We don't support system-wide installation
+ list(APPEND SYSTEM_INSTALL_DIRS "/usr/local" "/usr" "/opt/" "/opt/local" "c:/Program Files/${PROJECT_NAME}")
+ if(NOT DEFINED CMAKE_INSTALL_PREFIX OR CMAKE_INSTALL_PREFIX IN_LIST SYSTEM_INSTALL_DIRS)
+ message(WARNING "\
+ The default and system-level install directories are unsupported except in LTS \
+ releases of Abseil. Please set CMAKE_INSTALL_PREFIX to install Abseil in your \
+ source or build tree directly.\
+ ")
+ endif()
+ # absl:lts-remove-end
+
# install as a subdirectory only
install(EXPORT ${PROJECT_NAME}Targets
NAMESPACE absl::
@@ -140,7 +140,7 @@ if (ABSL_ENABLE_INSTALL)
# Abseil only has a version in LTS releases. This mechanism is accomplished
# Abseil's internal Copybara (https://github.com/google/copybara) workflows and
# isn't visible in the CMake buildsystem itself.
- if (absl_VERSION)
+ if(absl_VERSION)
write_basic_package_version_file(
"${PROJECT_BINARY_DIR}/${PROJECT_NAME}ConfigVersion.cmake"
COMPATIBILITY ExactVersion