summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules4
3 files changed, 3 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index e48b1b5d..ca40b912 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ abseil (0~20210324.0-1) UNRELEASED; urgency=medium
* Correct debian/watch search URLs to avoid picking up rc versions.
* Mangle upstream version in debian/watch to match manual mangling in
debian/changelog.
+ * Reenable unit tests on arm64.
-- Benjamin Barenblat <bbaren@debian.org> Thu, 08 Apr 2021 10:28:01 -0400
diff --git a/debian/control b/debian/control
index 3b8846f7..723d00c8 100644
--- a/debian/control
+++ b/debian/control
@@ -18,7 +18,7 @@ Maintainer: Benjamin Barenblat <bbaren@debian.org>
Build-Depends:
cmake (>= 3.5),
debhelper-compat (= 13),
- googletest (>= 1.10.0.20200926) [amd64 ppc64el],
+ googletest (>= 1.10.0.20200926) [amd64 arm64 ppc64el],
Rules-Requires-Root: no
Standards-Version: 4.5.1
Section: libs
diff --git a/debian/rules b/debian/rules
index 1ce42692..d9a52e99 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,9 +18,7 @@ include /usr/share/dpkg/architecture.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow reproducible=+fixfilepath
# Unit tests aren't working on all platforms yet.
-ifeq ($(DEB_HOST_ARCH),amd64)
-ABSL_RUN_TESTS=ON
-else ifeq ($(DEB_HOST_ARCH),ppc64el)
+ifneq ($(filter $(DEB_HOST_ARCH),amd64 arm64 ppc64el),)
ABSL_RUN_TESTS=ON
else
ABSL_RUN_TESTS=OFF