summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules5
3 files changed, 11 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 73763af3..ad5cbe09 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+abseil (0~20200923.2-2) unstable; urgency=medium
+
+ * Reenable unit tests.
+
+ -- Benjamin Barenblat <bbaren@debian.org> Tue, 01 Dec 2020 12:37:56 -0500
+
abseil (0~20200923.2-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/control b/debian/control
index b490ddce..2bf190c5 100644
--- a/debian/control
+++ b/debian/control
@@ -18,6 +18,7 @@ Maintainer: Benjamin Barenblat <bbaren@debian.org>
Build-Depends:
cmake (>= 3.5),
debhelper-compat (= 12),
+ googletest (>= 1.10.0.20200926),
Rules-Requires-Root: no
Standards-Version: 4.5.0
Section: libs
diff --git a/debian/rules b/debian/rules
index c6c94e3c..859e20ba 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,12 +24,15 @@ override_dh_auto_clean:
override_dh_auto_configure:
dh_auto_configure -Bstatic -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=OFF
- dh_auto_configure -Bshared -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=ON
+ dh_auto_configure -Bshared -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=ON -DABSL_RUN_TESTS=ON -DABSL_USE_GOOGLETEST_HEAD=OFF
override_dh_auto_build:
dh_auto_build -Bstatic
dh_auto_build -Bshared
+override_dh_auto_test:
+ dh_auto_test -Bshared
+
override_dh_auto_install:
dh_auto_install -Bstatic
dh_auto_install -Bshared