summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2022-08-30 22:40:57 -0400
committerGravatar Benjamin Barenblat <bbaren@google.com>2022-08-30 22:40:57 -0400
commitde1b4de8da1cb0127da16824c40d205a0d1c29aa (patch)
treeb217cb953151289a95231951fe09a3532697283c /debian
parent1da493fa0f1003aa14bfd59a64cb6fef8fe40f08 (diff)
Backport an upstream patch to fix pkg-config file generation
See https://github.com/abseil/abseil-cpp/pull/1216 (upstream commit 09e96049995584c3489e4bd1467313e3e85af99c) for full details.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/leaky-pkgconfig-cflags.diff16
-rw-r--r--debian/patches/series1
3 files changed, 23 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index e5a1c38c..8056265d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+abseil (0~20220623.0-2) UNRELEASED; urgency=medium
+
+ * Backport an upstream patch to correct pkg-config file generation.
+
+ -- Benjamin Barenblat <bbaren@debian.org> Tue, 30 Aug 2022 22:40:21 -0400
+
abseil (0~20220623.0-1) unstable; urgency=medium
* New upstream release. (Closes: #1008730, #1012194)
diff --git a/debian/patches/leaky-pkgconfig-cflags.diff b/debian/patches/leaky-pkgconfig-cflags.diff
new file mode 100644
index 00000000..cf1479d4
--- /dev/null
+++ b/debian/patches/leaky-pkgconfig-cflags.diff
@@ -0,0 +1,16 @@
+From: Bruno Pitrus <brunopitrus@hotmail.com>
+Subject: Do not leak -maes -msse4.1 into pkgconfig
+Forwarded: https://github.com/abseil/abseil-cpp/pull/1216
+Origin: upstream, https://github.com/abseil/abseil-cpp/commit/09e96049995584c3489e4bd1467313e3e85af99c
+
+--- a/CMake/AbseilHelpers.cmake
++++ b/CMake/AbseilHelpers.cmake
+@@ -166,6 +166,8 @@
+ set(PC_CFLAGS "${PC_CFLAGS} ${cflag}")
+ elseif(${cflag} MATCHES "^(-W|/w[1234eo])")
+ # Don't impose our warnings on others.
++ elseif(${cflag} MATCHES "^-m")
++ # Don't impose CPU instruction requirements on others, as the code performs feature detection on runtime.
+ else()
+ set(PC_CFLAGS "${PC_CFLAGS} ${cflag}")
+ endif()
diff --git a/debian/patches/series b/debian/patches/series
index b64772ac..c30e9953 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,3 +2,4 @@ configure.diff
cpu-features.diff
latomic.diff
empty-flags-library.diff
+leaky-pkgconfig-cflags.diff