summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2022-12-05 13:35:50 -0500
committerGravatar Benjamin Barenblat <bbaren@google.com>2022-12-05 13:35:50 -0500
commitf4f2c1da90c4e6a0683c4e66c0268baa1b79cdf3 (patch)
treec254dbe9830087234b26f18b02d82ff2fad8a685 /debian/rules
parentf5afcb784c9b1c501c1144b7aab84555881ca871 (diff)
Run tests serially on riscv64
Debian’s RISC-V builders don’t have enough resources to run Abseil’s test suite in parallel. See https://bugs.debian.org/1025221.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 0dbb698e..4a36943e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,6 +30,12 @@ else
ABSL_RUN_TESTS=ON
endif
+# Debian's RISC-V builders don't have enough resources to run tests in parallel.
+# See https://bugs.debian.org/1025221.
+ifneq ($(filter $(DEB_HOST_ARCH),riscv64),)
+ABSL_TEST_EXTRA_ARGS=--no-parallel
+endif
+
%:
dh $@
@@ -51,7 +57,7 @@ override_dh_auto_build:
ifeq ($(ABSL_RUN_TESTS),ON)
override_dh_auto_test:
- dh_auto_test -Bshared
+ dh_auto_test -Bshared $(ABSL_TEST_EXTRA_ARGS)
endif
override_dh_auto_install: