summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2023-06-27 17:03:22 -0400
committerGravatar Benjamin Barenblat <bbaren@google.com>2023-06-27 17:21:43 -0400
commiteb6db73f663df4eef48517a4dae62240c90783ff (patch)
tree921ad1a62cf27c88adbaee136879c07af84da699 /debian/rules
parentb01f2c97c728258cb9286a1b7a91ac0f767be12f (diff)
Run unit tests out of the `static` directory
136c2572f4d6e6ab8ae02f74d691634874458184 set tests to build in the `static` directory rather than the `shared` directory. Unfortunately, it neglected to set the tests to _run_ out of the `static` directory, which disabled all the tests. Set the tests to run out of `static`.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 16d92626..e835a80d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -53,7 +53,7 @@ override_dh_auto_build:
ifeq ($(ABSL_RUN_TESTS),ON)
override_dh_auto_test:
- dh_auto_test -Bshared $(ABSL_TEST_EXTRA_ARGS)
+ dh_auto_test -Bstatic $(ABSL_TEST_EXTRA_ARGS)
endif
override_dh_auto_install: