summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2020-05-12 18:20:27 -0400
committerGravatar Benjamin Barenblat <bbaren@google.com>2020-05-18 15:05:59 -0400
commite05aa44e16cc9c47c8285b920415ac0f4763657a (patch)
tree56af9c85a801d93d1beb720bfee1928db672490f /debian/rules
parentc51510d1d87ebce8615ae1752fd5aca912f6cf4c (diff)
Start packaging Abseil
Create basic packaging for Abseil. There’s still work to be done – there are no autopkgtests, and this package doesn’t install Abseil’s CMake integration. However, you can install the binary packages and build programs that link the libraries.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..79964920
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+# Copyright 2020 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may not
+# use this file except in compliance with the License. You may obtain a copy of
+# the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations under
+# the License.
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DCMAKE_CXX_STANDARD=14 -DABSL_RUN_TESTS=ON -DABSL_USE_GOOGLETEST_HEAD=OFF -DBUILD_SHARED_LIBS=ON
+
+override_dh_auto_install:
+ dh_auto_install
+ find debian/tmp -type d -empty -delete