summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2020-05-19 11:55:11 -0400
committerGravatar Benjamin Barenblat <bbaren@google.com>2020-05-19 11:55:11 -0400
commitacf588f5a22eafd7d21de55b954e8641d4b06568 (patch)
treeee689a9ef34982825e511f997f7b5b9ccb3d2b08 /debian/rules
parentf9adb234861d1321e0b8774db9aed57ebc6161f0 (diff)
Enable CMake support
Install Abseil’s CMake support files. Some of these files are autogenerated, and the generator produces files with a googletest dependency if Abseil is built with unit tests enabled; to prevent this, turn off unit tests.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 79964920..4c276263 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,7 +19,7 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow
dh $@
override_dh_auto_configure:
- dh_auto_configure -- -DCMAKE_CXX_STANDARD=14 -DABSL_RUN_TESTS=ON -DABSL_USE_GOOGLETEST_HEAD=OFF -DBUILD_SHARED_LIBS=ON
+ dh_auto_configure -- -DCMAKE_CXX_STANDARD=14 -DBUILD_SHARED_LIBS=ON
override_dh_auto_install:
dh_auto_install