summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2022-10-18 08:37:23 -0400
committerGravatar Benjamin Barenblat <bbaren@google.com>2022-10-18 08:37:23 -0400
commit30f359b8df30cb72f2505f1e843e6054d01c8bdd (patch)
treea0bd1f9c651d619402391b47f387c69c928b1a8b /debian/rules
parent6c810c2fadb33f0a1e68bfc63cd2217b3972f40f (diff)
Support nocheck profile
Per release-team’s recent request that maintainers support the nocheck profile <E1oit90-0073rh-LX@respighi.debian.org>, annotate googletest with <!nocheck> and disable tests in debian/rules if that profile is set.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 86492154..0dbb698e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,8 +20,12 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow reproducible=+fixfilepath
# Unit tests require more than 2 GB of RAM, so disable them on mipsel.
#
# Unit tests are not yet passing on ppc64, so disable them there as well.
+#
+# Disable unit tests unconditionally if nocheck is set.
ifneq ($(filter $(DEB_HOST_ARCH),mipsel ppc64),)
ABSL_RUN_TESTS=OFF
+else ifneq ($(filter nocheck,$(DEB_BUILD_OPTIONS)),)
+ABSL_RUN_TESTS=OFF
else
ABSL_RUN_TESTS=ON
endif