summaryrefslogtreecommitdiff
path: root/debian/patches/overload-test-dependencies.diff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2024-05-08 16:14:49 -0400
committerGravatar Benjamin Barenblat <bbaren@google.com>2024-05-08 16:14:49 -0400
commit109b466e90381167a83da3eaadb0dbf72e66f210 (patch)
treed1223168297c08e67b581eb4023fd1a2b137fcb7 /debian/patches/overload-test-dependencies.diff
parent9aa75a5044aac4062db95538304d281c2b5d710b (diff)
Backport a patch from upstream to fix overload_test
Diffstat (limited to 'debian/patches/overload-test-dependencies.diff')
-rw-r--r--debian/patches/overload-test-dependencies.diff27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/patches/overload-test-dependencies.diff b/debian/patches/overload-test-dependencies.diff
new file mode 100644
index 00000000..fb843c91
--- /dev/null
+++ b/debian/patches/overload-test-dependencies.diff
@@ -0,0 +1,27 @@
+From: Benjamin Barenblat <bbaren@google.com>
+Subject: Resynchronize absl/functional/CMakeLists.txt with BUILD.bazel
+Forwarded: yes
+Applied-Upstream: https://github.com/abseil/abseil-cpp/commit/7b87d959346cab4ab9829724efee377f7fb254ed
+
+overload_test needs some extra dependencies to build when absl::variant
+is not an alias for std::variant; these dependencies are listed in
+absl/functional/BUILD.bazel but not in absl/functional/CMakeLists.txt.
+Copy dependencies from BUILD.bazel to CMakeLists.txt.
+
+The author works at Google. Upstream applied this patch as Piper
+revision 631845552 and exported it to GitHub; the Applied-Upstream URL
+above points to the exported commit.
+
+--- a/absl/functional/CMakeLists.txt
++++ b/absl/functional/CMakeLists.txt
+@@ -129,6 +129,10 @@
+ COPTS
+ ${ABSL_TEST_COPTS}
+ DEPS
++ absl::config
++ absl::overload
++ absl::string_view
+ absl::strings
++ absl::variant
+ GTest::gmock_main
+ )