summaryrefslogtreecommitdiff
path: root/debian/patches/empty-flags-library.diff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2022-01-31 17:40:57 -0500
committerGravatar Benjamin Barenblat <bbaren@google.com>2022-01-31 18:04:18 -0500
commite4d8b08c9162b2a4fcdaa186d66073ecf19256ef (patch)
treef3ba053c521b88e802003bb226bde4d9ac33cd78 /debian/patches/empty-flags-library.diff
parent8bd0ae5f71bfbbe3509f644cba58157810b65269 (diff)
Make flags library header-only
The Abseil flags library needs to emit code only when being compiled with MSVC, which Debian doesn’t use. Skip absl/flags/flag.cc, and tell CMake to treat the flags library as header-only.
Diffstat (limited to 'debian/patches/empty-flags-library.diff')
-rw-r--r--debian/patches/empty-flags-library.diff19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/patches/empty-flags-library.diff b/debian/patches/empty-flags-library.diff
new file mode 100644
index 00000000..fe1d3962
--- /dev/null
+++ b/debian/patches/empty-flags-library.diff
@@ -0,0 +1,19 @@
+From: Benjamin Barenblat <bbaren@google.com>
+Subject: Eliminate libabsl_flags.so and libabsl_flags.a
+Forwarded: not-needed
+
+The libabsl_flags library only contains code when compiling with MSVC, which
+Debian doesn't use. Skip compiling absl/flags/flag.cc, and make the Abseil flags
+library header-only.
+
+--- a/absl/flags/CMakeLists.txt
++++ b/absl/flags/CMakeLists.txt
+@@ -197,8 +197,6 @@
+ absl_cc_library(
+ NAME
+ flags
+- SRCS
+- "flag.cc"
+ HDRS
+ "declare.h"
+ "flag.h"