summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2020-05-12 18:20:27 -0400
committerGravatar Benjamin Barenblat <bbaren@google.com>2020-05-18 15:05:59 -0400
commite05aa44e16cc9c47c8285b920415ac0f4763657a (patch)
tree56af9c85a801d93d1beb720bfee1928db672490f /debian/control
parentc51510d1d87ebce8615ae1752fd5aca912f6cf4c (diff)
Start packaging Abseil
Create basic packaging for Abseil. There’s still work to be done – there are no autopkgtests, and this package doesn’t install Abseil’s CMake integration. However, you can install the binary packages and build programs that link the libraries.
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control631
1 files changed, 631 insertions, 0 deletions
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..f43bd41a
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,631 @@
+# Copyright 2020 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may not
+# use this file except in compliance with the License. You may obtain a copy of
+# the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations under
+# the License.
+
+Source: abseil
+Priority: optional
+Maintainer: Benjamin Barenblat <bbaren@debian.org>
+Build-Depends:
+ cmake (>= 3.5),
+ debhelper-compat (= 12),
+ googletest,
+Standards-Version: 4.5.0
+Section: libs
+Homepage: https://abseil.io/
+Description: extensions to the C++ standard library
+ Abseil is an open-source collection of C++ library code designed to augment the
+ C++ standard library. The Abseil library code is collected from Google's C++
+ codebase and has been extensively tested and used in production. In some cases,
+ Abseil provides pieces missing from the C++ standard; in others, Abseil
+ provides alternatives to the standard for special needs.
+
+Package: libabsl-dev
+Architecture: any
+Multi-Arch: same
+Section: libdevel
+Depends:
+ libabsl-bad-any-cast-impl20200225 (= ${binary:Version}),
+ libabsl-bad-optional-access20200225 (= ${binary:Version}),
+ libabsl-bad-variant-access20200225 (= ${binary:Version}),
+ libabsl-base20200225 (= ${binary:Version}),
+ libabsl-city20200225 (= ${binary:Version}),
+ libabsl-civil-time20200225 (= ${binary:Version}),
+ libabsl-cord20200225 (= ${binary:Version}),
+ libabsl-debugging-internal20200225 (= ${binary:Version}),
+ libabsl-demangle-internal20200225 (= ${binary:Version}),
+ libabsl-dynamic-annotations20200225 (= ${binary:Version}),
+ libabsl-examine-stack20200225 (= ${binary:Version}),
+ libabsl-exponential-biased20200225 (= ${binary:Version}),
+ libabsl-failure-signal-handler20200225 (= ${binary:Version}),
+ libabsl-flags20200225 (= ${binary:Version}),
+ libabsl-flags-config20200225 (= ${binary:Version}),
+ libabsl-flags-internal20200225 (= ${binary:Version}),
+ libabsl-flags-marshalling20200225 (= ${binary:Version}),
+ libabsl-flags-parse20200225 (= ${binary:Version}),
+ libabsl-flags-program-name20200225 (= ${binary:Version}),
+ libabsl-flags-registry20200225 (= ${binary:Version}),
+ libabsl-flags-usage20200225 (= ${binary:Version}),
+ libabsl-flags-usage-internal20200225 (= ${binary:Version}),
+ libabsl-graphcycles-internal20200225 (= ${binary:Version}),
+ libabsl-hash20200225 (= ${binary:Version}),
+ libabsl-hashtablez-sampler20200225 (= ${binary:Version}),
+ libabsl-int128-20200225 (= ${binary:Version}),
+ libabsl-leak-check20200225 (= ${binary:Version}),
+ libabsl-leak-check-disable20200225 (= ${binary:Version}),
+ libabsl-log-severity20200225 (= ${binary:Version}),
+ libabsl-malloc-internal20200225 (= ${binary:Version}),
+ libabsl-periodic-sampler20200225 (= ${binary:Version}),
+ libabsl-random-distributions20200225 (= ${binary:Version}),
+ libabsl-random-internal-distr-testutil20200225 (= ${binary:Version}),
+ libabsl-random-internal-pool-urbg20200225 (= ${binary:Version}),
+ libabsl-random-internal-randen20200225 (= ${binary:Version}),
+ libabsl-random-internal-randen-hwaes20200225 (= ${binary:Version}),
+ libabsl-random-internal-randen-hwaes-i20200225 (= ${binary:Version}),
+ libabsl-random-internal-randen-slow20200225 (= ${binary:Version}),
+ libabsl-random-internal-seed-material20200225 (= ${binary:Version}),
+ libabsl-random-seed-gen-exception20200225 (= ${binary:Version}),
+ libabsl-random-seed-sequences20200225 (= ${binary:Version}),
+ libabsl-raw-hash-set20200225 (= ${binary:Version}),
+ libabsl-raw-logging-internal20200225 (= ${binary:Version}),
+ libabsl-scoped-set-env20200225 (= ${binary:Version}),
+ libabsl-spinlock-wait20200225 (= ${binary:Version}),
+ libabsl-stacktrace20200225 (= ${binary:Version}),
+ libabsl-status20200225 (= ${binary:Version}),
+ libabsl-str-format-internal20200225 (= ${binary:Version}),
+ libabsl-strings20200225 (= ${binary:Version}),
+ libabsl-strings-internal20200225 (= ${binary:Version}),
+ libabsl-symbolize20200225 (= ${binary:Version}),
+ libabsl-synchronization20200225 (= ${binary:Version}),
+ libabsl-throw-delegate20200225 (= ${binary:Version}),
+ libabsl-time20200225 (= ${binary:Version}),
+ libabsl-time-zone20200225 (= ${binary:Version}),
+ ${misc:Depends},
+Recommends: g++ (>= 4.7), libgmock-dev, libgtest-dev
+Description: ${source:Synopsis} (development files)
+ ${source:Extended-Description}
+ .
+ This package contains header files and other data necessary for developing with
+ Abseil.
+
+Package: libabsl-bad-any-cast-impl20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- absl::bad_any_cast
+ ${source:Extended-Description}
+ .
+ This package contains the absl::bad_any_cast type, a reimplementation of the
+ C++17 std::bad_any_cast type.
+
+Package: libabsl-bad-optional-access20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- absl::bad_optional_access
+ ${source:Extended-Description}
+ .
+ This package contains the absl::bad_optional_access type, a reimplementation of
+ the C++17 std::bad_optional_access type.
+
+Package: libabsl-bad-variant-access20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- absl::bad_variant_access
+ ${source:Extended-Description}
+ .
+ This package contains the absl::bad_variant_access type, a reimplementation of
+ the C++17 std::bad_variant_access type.
+
+Package: libabsl-base20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- base functionality
+ ${source:Extended-Description}
+ .
+ This package contains the Abseil base, a set of low-level types and functions
+ that support other Abseil functionality.
+
+Package: libabsl-city20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- string hash functions
+ ${source:Extended-Description}
+ .
+ This package contains CityHash, a family of fast and high-quality functions for
+ hashing strings. While suitable for use in a hash table, CityHash is not
+ cryptographically secure.
+
+Package: libabsl-civil-time20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- human-scale time
+ ${source:Extended-Description}
+ .
+ This package contains absl::CivilDay, a type representing legally recognized
+ human-scale time that is represented by the six fields "YYYY-MM-DD hh:mm:ss".
+
+Package: libabsl-cord20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- copy-on-write character sequences
+ ${source:Extended-Description}
+ .
+ This package contains absl::Cord, a copy-on-write character sequence type.
+ Unlike std::string, absl::Cord supports efficient insertions and deletions at
+ both the start and end of the byte sequence; on the other hand, random-access
+ reads are slow, and random-access writes are unsupported.
+
+Package: libabsl-debugging-internal20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- debugging support
+ ${source:Extended-Description}
+ .
+ This package contains low-level routines for implementing debugging aids.
+
+Package: libabsl-demangle-internal20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- demangling support
+ ${source:Extended-Description}
+ .
+ This package contains an async-signal-safe and thread-safe demangler for the
+ Itanium (GCC) C++ ABI.
+
+Package: libabsl-dynamic-annotations20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- dynamic annotations
+ ${source:Extended-Description}
+ .
+ This package supports dynamic annotations, source code annotations that inform
+ code generation. Currently, Thread Sanitizer and compiler-enforced
+ thread-safety annotations are available.
+
+Package: libabsl-examine-stack20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- stack traces
+ ${source:Extended-Description}
+ .
+ This package contains a function to dump stack traces in a human-readable
+ manner.
+
+Package: libabsl-exponential-biased20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- rounded exponential distribution
+ ${source:Extended-Description}
+ .
+ This package contains a pseudorandom number generator for a rounded exponential
+ distribution. While small and fast, the generator is not cryptographically
+ secure.
+
+Package: libabsl-failure-signal-handler20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- signal handler to print debug info
+ ${source:Extended-Description}
+ .
+ This package contains a signal handler that will capture and useful debugging
+ information before exiting.
+
+Package: libabsl-flags-config20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- usage message configuration
+ ${source:Extended-Description}
+ .
+ This package provides code to control how programs display usage information.
+
+Package: libabsl-flags-internal20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- internal command-line flag handling
+ ${source:Extended-Description}
+ .
+ This package contains internal code for handling command-line flags.
+
+Package: libabsl-flags-marshalling20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- custom types in command-line flags
+ ${source:Extended-Description}
+ .
+ This package allows parsing custom types as command-line flags.
+
+Package: libabsl-flags-parse20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- command-line flag parsing
+ ${source:Extended-Description}
+ .
+ This package contains absl::ParseCommandLine, the main entry point to the
+ Abseil command-line flag subsystem.
+
+Package: libabsl-flags-program-name20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- inspecting the program name
+ ${source:Extended-Description}
+ .
+ This package contains functions to get the name under which a program was
+ invoked.
+
+Package: libabsl-flags-registry20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- command-line flags in libraries
+ ${source:Extended-Description}
+ .
+ This package contains functions to let libraries register command-line flags.
+
+Package: libabsl-flags20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- command-line flags
+ ${source:Extended-Description}
+ .
+ This package contains the absl::Flag<T> type, which holds command-line flag
+ data, and abstractions to create, get, and set such flag data.
+
+Package: libabsl-flags-usage-internal20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- usage messages
+ ${source:Extended-Description}
+ .
+ This package contains internal code to display program usage information.
+
+Package: libabsl-flags-usage20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- usage messages
+ ${source:Extended-Description}
+ .
+ This package contains code to display program usage information.
+
+Package: libabsl-graphcycles-internal20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- digraph cycle detection
+ ${source:Extended-Description}
+ .
+ This package contains code to detect cycles in directed graphs.
+
+Package: libabsl-hash20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- general hashing
+ ${source:Extended-Description}
+ .
+ This package contains the Abseil hash library and hashing framework.
+
+Package: libabsl-hashtablez-sampler20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- hash-table runtime statistics
+ ${source:Extended-Description}
+ .
+ This package contains the hashtablez sampler, a low-level library to sample
+ hash tables and collect runtime statistics about them.
+
+Package: libabsl-int128-20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- 128-bit integers
+ ${source:Extended-Description}
+ .
+ This package defines types to represent 128-bit integers.
+
+Package: libabsl-leak-check-disable20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- disable memory leak detection
+ ${source:Extended-Description}
+ .
+ This package contains a symbol which, when linked, disables Abseil's
+ LeakSanitizer.
+
+Package: libabsl-leak-check20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- memory leak detector
+ ${source:Extended-Description}
+ .
+ This package contains LeakSanitizer, a memory leak detector.
+
+Package: libabsl-log-severity20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- log severity levels
+ ${source:Extended-Description}
+ .
+ This package defines log severity levels useful in logging libraries.
+
+Package: libabsl-malloc-internal20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- low-level allocation
+ ${source:Extended-Description}
+ .
+ This package contains low-level functions for dealing with memory allocation.
+
+Package: libabsl-periodic-sampler20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- runtime sampling
+ ${source:Extended-Description}
+ .
+ This package contains code to periodically sample statistics about the running
+ program.
+
+Package: libabsl-random-distributions20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- probability distributions
+ ${source:Extended-Description}
+ .
+ This package contains implementations of most common probability distributions.
+
+Package: libabsl-random-internal-distr-testutil20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- test utilities
+ ${source:Extended-Description}
+ .
+ This package contains internal code for testing probability distributions.
+
+Package: libabsl-random-internal-pool-urbg20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- random bit generator
+ ${source:Extended-Description}
+ .
+ This package contains a thread-safe pseudorandom number generator.
+
+Package: libabsl-random-internal-randen-hwaes-i20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- AES-based PRNG
+ ${source:Extended-Description}
+ .
+ This package contains a thread-safe pseudorandom number generator based on
+ hardware-accelerated AES instructions.
+
+Package: libabsl-random-internal-randen-hwaes20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- AES instruction detection
+ ${source:Extended-Description}
+ .
+ This package contains code to detect whether or not hardware AES support is
+ available.
+
+Package: libabsl-random-internal-randen-slow20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- non-AES-based PRNG
+ ${source:Extended-Description}
+ .
+ This package contains a thread-safe pseudorandom number generator for systems
+ that lack hardware-accelerated AES instructions.
+
+Package: libabsl-random-internal-randen20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- PRNG interface
+ ${source:Extended-Description}
+ .
+ This package contains an interface for thread-safe pseudorandom number
+ generators.
+
+Package: libabsl-random-internal-seed-material20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- operating system entropy
+ ${source:Extended-Description}
+ .
+ This package contains functions to get entropy from the operating system.
+
+Package: libabsl-random-seed-gen-exception20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- absl::SeedGenException
+ ${source:Extended-Description}
+ .
+ This package contains absl::SeedGenException, an exception indicating that
+ system entropy is unavailable.
+
+Package: libabsl-random-seed-sequences20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- absl::SeedSeq
+ ${source:Extended-Description}
+ .
+ This package contains absl::SeedSeq, a C++17-compliant seed sequence. Unlike
+ std::seed_seq, it salts the generated seeds with extra entropy.
+
+Package: libabsl-raw-hash-set20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- low-level hash table
+ ${source:Extended-Description}
+ .
+ This package contains a low-level hash table with quadratic probing.
+
+Package: libabsl-raw-logging-internal20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- low-level logging
+ ${source:Extended-Description}
+ .
+ This package contains low-level thread-safe logging routines.
+
+Package: libabsl-scoped-set-env20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- RAII setenv wrapper
+ ${source:Extended-Description}
+ .
+ This package contains an RAII class to temporarily modify the process
+ environment.
+
+Package: libabsl-spinlock-wait20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- spinlock waiter
+ ${source:Extended-Description}
+ .
+ This package contains functions that wait for spin locks to become available.
+
+Package: libabsl-stacktrace20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- stack introspection
+ ${source:Extended-Description}
+ .
+ This package contains thread-safe and async-signal-safe functions to inspect
+ the stack.
+
+Package: libabsl-status20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- result codes
+ ${source:Extended-Description}
+ .
+ This package contains a generic result code library.
+
+Package: libabsl-str-format-internal20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- stringification
+ ${source:Extended-Description}
+ .
+ This package contains low-level functions for converting various data types to
+ strings.
+
+Package: libabsl-strings-internal20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- low-level string utilities
+ ${source:Extended-Description}
+ .
+ This package contains low-level functions for operating on strings.
+
+Package: libabsl-strings20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- string utilities
+ ${source:Extended-Description}
+ .
+ This package contains many useful functions for operating on strings, including
+ highly generic functions for stringification, concatenation, and substitution.
+
+Package: libabsl-symbolize20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- address symbolizer
+ ${source:Extended-Description}
+ .
+ This package contains the Abseil symbolizer, which converts program counters
+ into human-readable addresses.
+
+Package: libabsl-synchronization20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- synchronization primitives
+ ${source:Extended-Description}
+ .
+ This package contains many useful synchronization primitives, including
+ efficient locks, condition variables, notification flags, and barriers.
+
+Package: libabsl-throw-delegate20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- exception-throwing
+ ${source:Extended-Description}
+ .
+ This package contains helper functions that allow throwing exceptions
+ consistently from anywhere.
+
+Package: libabsl-time20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- timestamps and durations
+ ${source:Extended-Description}
+ .
+ This package contains many useful abstractions for computing with timestamps
+ and durations of time. It also defines functions for formatting and parsing
+ times.
+
+Package: libabsl-time-zone20200225
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: ${source:Synopsis} -- time zones
+ ${source:Extended-Description}
+ .
+ This package contains Abseil's time zone support.