summaryrefslogtreecommitdiff
path: root/absl/time/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gennadiy Rozental <rogeeff@google.com>2022-10-18 02:34:29 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2022-10-18 02:35:17 -0700
commit4bc7568c70822dae40eea3f27a3051a618021651 (patch)
treeb7e9ef7372a4ff1daad77af2eb84e2b230dfc506 /absl/time/CMakeLists.txt
parent94433ef0615616b1ccb8b2193bde777c10406ac0 (diff)
Eliminate use of internal interfaces and make the test portable and expose it to OSS.
PiperOrigin-RevId: 481865072 Change-Id: I46364ec07df6aaff25911f8bd9e40dfee6c60626
Diffstat (limited to 'absl/time/CMakeLists.txt')
-rw-r--r--absl/time/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/absl/time/CMakeLists.txt b/absl/time/CMakeLists.txt
index debab3ba..1580a303 100644
--- a/absl/time/CMakeLists.txt
+++ b/absl/time/CMakeLists.txt
@@ -127,3 +127,16 @@ absl_cc_test(
absl::time_zone
GTest::gmock_main
)
+
+absl_cc_test(
+ NAME
+ flag_test
+ SRCS
+ "flag_test.cc"
+ COPTS
+ ${ABSL_TEST_COPTS}
+ DEPS
+ absl::flags
+ absl::flags_reflection
+ GTest::gmock_main
+)