summaryrefslogtreecommitdiff
path: root/absl/synchronization/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Derek Mauro <dmauro@google.com>2023-04-13 10:25:13 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2023-04-13 10:25:56 -0700
commitc5f310de3ba06b7ad24da48145a099485322d2ac (patch)
tree3e4763c246fc38083692dd7b15daf9c4ed60a137 /absl/synchronization/CMakeLists.txt
parentc23acb9b5636e7b908fba03d6b3584d8f80dba6d (diff)
Don't override clock_gettime in the KernelTimeout and Waiter
tests under sanitizers. The overrides break the sanitizers. PiperOrigin-RevId: 524037272 Change-Id: I85b87d3870c488cb316505e94b394c6f98e9f60f
Diffstat (limited to 'absl/synchronization/CMakeLists.txt')
-rw-r--r--absl/synchronization/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/absl/synchronization/CMakeLists.txt b/absl/synchronization/CMakeLists.txt
index b6b3b27c..86278349 100644
--- a/absl/synchronization/CMakeLists.txt
+++ b/absl/synchronization/CMakeLists.txt
@@ -259,6 +259,7 @@ absl_cc_test(
COPTS
${ABSL_TEST_COPTS}
DEPS
+ absl::config
absl::kernel_timeout_internal
absl::random_random
absl::synchronization