summaryrefslogtreecommitdiff
path: root/absl/strings/str_format.h
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2020-04-24 06:12:31 -0700
committerGravatar Derek Mauro <dmauro@google.com>2020-04-24 12:53:15 -0400
commitcde2e2410e58c884b3bf5f67c6511e6266036249 (patch)
treefc39c20897f77e5ded41fc5601462d1f12350bba /absl/strings/str_format.h
parent68494aae959dfbbf781cdf03a988d2f5fc7e4802 (diff)
Export of internal Abseil changes
-- 2aa4544070113a4943f93464df74759f043bab92 by CJ Johnson <johnsoncj@google.com>: Spelling fix in InlinedVector PiperOrigin-RevId: 308241764 -- 0d8a8ff71023df845c490c73811da598a42f12d9 by Todd Jackson <tjackson@google.com>: Fix CMake warnings on absl/types/CMakeLists.txt. PiperOrigin-RevId: 308123331 -- f35fbd79437ba999097b1499770103b7865078e5 by Samuel Benzaquen <sbenza@google.com>: Speed up the integral printer. PiperOrigin-RevId: 308081531 -- b1676b869ed0547e1cca23c83bb370f459bdf2cb by Samuel Benzaquen <sbenza@google.com>: Collapse the template arguments to enums earlier to reduce the number of instantiations of FormatSpecTemplate. This doesn't affect opt builds much, but reduces the bloat in non-opt builds. PiperOrigin-RevId: 308066155 -- edda0c227adad392cfff2af6ed532822c481f013 by Abseil Team <absl-team@google.com>: Minor documentation fix for `absl::Status` CTOR. PiperOrigin-RevId: 308037725 -- 8326b85569f0fdb15632b0076e38baba4c69794b by Derek Mauro <dmauro@google.com>: Internal change PiperOrigin-RevId: 307914168 GitOrigin-RevId: 2aa4544070113a4943f93464df74759f043bab92 Change-Id: I553ce3838c5e35d04954f560dc75ec24033919af
Diffstat (limited to 'absl/strings/str_format.h')
-rw-r--r--absl/strings/str_format.h4
1 files changed, 2 insertions, 2 deletions
diff --git a/absl/strings/str_format.h b/absl/strings/str_format.h
index 2e0b33f7..f48510b4 100644
--- a/absl/strings/str_format.h
+++ b/absl/strings/str_format.h
@@ -254,8 +254,8 @@ class FormatCountCapture {
// argument, etc.
template <typename... Args>
-using FormatSpec =
- typename str_format_internal::FormatSpecDeductionBarrier<Args...>::type;
+using FormatSpec = str_format_internal::FormatSpecTemplate<
+ str_format_internal::ArgumentToConv<Args>()...>;
// ParsedFormat
//