summaryrefslogtreecommitdiff
path: root/absl/strings/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2021-04-16 11:25:33 -0700
committerGravatar Dino Radaković <dinor@google.com>2021-04-16 15:13:33 -0700
commit732c6540c19610d2653ce73c09eb6cb66da15f42 (patch)
tree7eb4345f016543b4c384afd946cfec1306048889 /absl/strings/CMakeLists.txt
parente20fe888fabc1fc995dc61180e8a31b5f809a95f (diff)
Export of internal Abseil changes
-- c7ce91501834b225bc9cf2d3fa2a319dd0b7f864 by Martijn Vels <mvels@google.com>: Implement global data for CordzHandle in an ODR hardened way This change puts the global data into a global delete queue structure, and stores a reference to the global data in the handle itself. This hardens the implementation against ODR violations where handles are crossing dynamic library boundaries which are privately loaded. PiperOrigin-RevId: 368885636 GitOrigin-RevId: c7ce91501834b225bc9cf2d3fa2a319dd0b7f864 Change-Id: I9775151a760b30989dec9517e4bcd2183e8c1651
Diffstat (limited to 'absl/strings/CMakeLists.txt')
-rw-r--r--absl/strings/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/absl/strings/CMakeLists.txt b/absl/strings/CMakeLists.txt
index 044e38b3..8f41f064 100644
--- a/absl/strings/CMakeLists.txt
+++ b/absl/strings/CMakeLists.txt
@@ -655,6 +655,7 @@ absl_cc_library(
${ABSL_DEFAULT_COPTS}
DEPS
absl::config
+ absl::raw_logging_internal
absl::synchronization
)