summaryrefslogtreecommitdiff
path: root/absl/status/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Pavel Samolysov <samolisov@gmail.com>2020-04-15 00:25:55 +0300
committerGravatar GitHub <noreply@github.com>2020-04-14 17:25:55 -0400
commit2946ac0dea49c894215a998aebb19d2f1d942909 (patch)
treec0fbefaa60b39e767a1fa634334c05f248e25f32 /absl/status/CMakeLists.txt
parent567bee2f7393fca6ca737ecf061bd9f97302e346 (diff)
Use base_internal::AtomicHook instead of std::atomic (#661)
* Use base_internal::AtomicHook instead of std::atomic std::atomic has a broken implementation on the Windows platform and it is not conform to the ABSL_CONST_INIT macro when clang-cl is used as a compiler: the macro is expanded to the [[clang::require_constant_initialization]] attribute and the attribute cannot be applied to the broken std::atomic. Therefore, std::atomic has been replaced with absl::base_internal::AtomicHook to fix the compilation error (thank Derek Mauro for the suggestion). Issue: #659 Signed-off-by: Pavel Samolysov <samolisov@gmail.com> * Update build files for pull request Co-authored-by: Derek Mauro <dmauro@google.com>
Diffstat (limited to 'absl/status/CMakeLists.txt')
-rw-r--r--absl/status/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/absl/status/CMakeLists.txt b/absl/status/CMakeLists.txt
index f05cee5e..c041d695 100644
--- a/absl/status/CMakeLists.txt
+++ b/absl/status/CMakeLists.txt
@@ -25,6 +25,7 @@ absl_cc_library(
COPTS
${ABSL_DEFAULT_COPTS}
DEPS
+ absl::atomic_hook
absl::config
absl::core_headers
absl::raw_logging_internal